Ask Your Question
0

my topic 'scan' was change to 'base_scan'

asked 2018-03-06 00:51:38 -0600

liu huxian gravatar image

updated 2018-03-06 14:02:53 -0600

jayess gravatar image

i can successfully run the command

roslaunch rplidar_ros rplidar.launch

then i found i cannot found the topic scan created by rplidar_node,but a topic named base_scan created by rplidar_node. what can i do to let the topic base_scan back to scan?

edit retag flag offensive close merge delete

Comments

you can also edit the rplidar.launch file to change the topic name to suit your need.

chrissunny94 gravatar imagechrissunny94 ( 2018-03-06 02:35:55 -0600 )edit

@chrissunny94 It's not a good idea to edit other packages' source (including launch files). If/when the package is updated then the modified source is gone. @Delb's answer is correct, modify your own source, which is under your control.

jayess gravatar imagejayess ( 2018-03-06 14:04:21 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-03-06 02:20:34 -0600

Delb gravatar image

Have you changed the launch file / rplidar_node? It's normally set to publish on scan.

You can remap the topics with the tag <remap> in your launch file :

<remap from="base_scan" to="scan"/>
edit flag offensive delete link more

Comments

i haven't changed my the launch file / rplidar_node. but after remap the topics with the tag <remap> in your launch file according to your answer ,i solved my problem, thought i still cannot figureout how this issue happen.thanks a lot for your answering!!

liu huxian gravatar imageliu huxian ( 2018-03-07 01:35:12 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-06 00:51:38 -0600

Seen: 180 times

Last updated: Mar 06 '18