fail to call service /get_planning_scene

asked 2018-02-22 19:22:37 -0500

Oh233 gravatar image

updated 2020-03-31 05:23:16 -0500

Dear all,

What I am doing is receiving depth and rgb images and converting them into pointcloud which will be used by moveit to generate actomap. I have successfully used freenect to build octomap in moveit. Everything worked fine.

Since I need to receive images from another camera, I wrote code to receive images and publish on certain topics to let depth_image_proc to subscribe and do the process. I have finished all the things about generating pointcloud and it did have pointcloud published on the certain topic. But when I ran move_group and rviz, there were one warning and error. Warning is

Failed to call service /get_planning_scene, have you launched move_group?.

Error is

Unable to connect to move_group action server within allotted time.

But I did run move_group node since I can see move_group node was subscribing the topic that published pointcloud. Does it relate with tf? Since before I ran static transform publisher for my world and camera frames, rviz won't crash because of failure to call service.

Thanks for any help in advance.

edit retag flag offensive close merge delete

Comments

This error is typically seen if move_group doesn't load (or can't successfully initialise) some particular plugins. Are there any additional errors or warnings? Did you change anything in the MoveIt configuration package for your robot?

gvdhoorn gravatar image gvdhoorn  ( 2018-02-23 03:46:57 -0500 )edit

There was no other warnings and errors and I did change somethings in MoveIt package but it is not related with scene but with planning context. Any suggestions of how or where to start to debug this problem?

Oh233 gravatar image Oh233  ( 2018-02-23 15:26:48 -0500 )edit

can you please post the output of : rosservice list | grep get_planning_scene?

Oscar Lima gravatar image Oscar Lima  ( 2018-10-17 14:09:44 -0500 )edit

i am facing similar problem and my output to this cmd shows "/get_planning_scene"

dharmendra gravatar image dharmendra  ( 2020-03-31 04:59:30 -0500 )edit

this is not a solution, but if you click "reset" button on the bottom bar in RViz, everything is refreshed and planning stuff appear...

roberto colella gravatar image roberto colella  ( 2020-05-17 11:00:54 -0500 )edit