ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rviz: symbol lookup error

asked 2018-02-12 17:23:10 -0500

rb gravatar image

updated 2018-02-13 01:40:46 -0500

jayess gravatar image

Fresh Ros Kinetic install on Ubuntu 16.04 (installed today). Try to launch RVIZ and get this error:

rviz: symbol lookup error: /opt/ros/kinetic/lib/ undefined symbol:

Things i've tried (that have not worked):

  • Rebooting
  • sudo apt dist-upgrade
  • googling this problem
  • Deleting, and remaking my catkin workspace.

Possibly relevant info:

This is a pretty standard installation of Ubuntu + ROS and the system install is pretty fresh as well. Only non-standard stuff I've done so far is I've installed nVidia video drivers to make a 1080 TI video card work and I've updated the kernel to version 4.15.2 to resolve a system clock drift issue with i9 processors.

edit retag flag offensive close merge delete


It's missing a Qt symbol, is Qt installed and if so, what version?

William gravatar image William  ( 2018-02-12 17:29:14 -0500 )edit

Also, did you install rviz from apt or did you build it from source? If not from source, what's in your catkin workspace that might affect rviz? Are you using any custom rviz plugins? Can you start rviz if you use the default configuration?

William gravatar image William  ( 2018-02-12 17:31:38 -0500 )edit

I just tried it on my 16.04 machine (sudo apt update; sudo apt dist-upgrade) and rviz runs fine. You can run the default configuration with rviz -d /opt/ros/kinetic/share/rviz/default.rviz (assuming you installed from debs).

William gravatar image William  ( 2018-02-12 17:39:49 -0500 )edit

QT 4.8.7 and qt 5.5.1 are installed. Running with default configuration makes no difference, identical error (Since this is first time opening RViz it should be default config anyway)

rb gravatar image rb  ( 2018-02-13 11:27:27 -0500 )edit

Perhaps it is picking up Qt4 instead of Qt5? I'm not sure why/how that would happen, but it could cause the symbol issues you're seeing.

William gravatar image William  ( 2018-02-13 16:39:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-02-13 17:05:19 -0500

rb gravatar image

updated 2018-02-13 17:06:23 -0500

Problem solved. Turned out that rviz was grabbing the wrong QT dependencies from an unrelated program installed on the computer. Thanks William for tips of looking into QT.


$ ldd /opt/ros/kinetic/lib/ | grep Qt => /opt/EVT/eCapture/QT/lib/ (0x00007fd0ad22c000) => /opt/EVT/eCapture/QT/lib/ (0x00007fd0ab053000) => /opt/EVT/eCapture/QT/lib/ (0x00007fd0aa9c9000)


export LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/:$LD_LIBRARY_PATH


$ ldd /opt/ros/kinetic/lib/ | grep Qt => /usr/lib/x86_64-linux-gnu/ (0x00007ff360453000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff35e38a000) => /usr/lib/x86_64-linux-gnu/ (0x00007ff35deb4000)
edit flag offensive delete link more



Hi, I have ubuntu 18.04 and ros melodic running and I am facing the same issue.

When I execute:

ldd /opt/ros/melodic/lib/ | grep Qt

I am already getting => /usr/lib/x86_64-linux-gnu/ (0x00007f997c7a3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f997a45a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f9979d0f000)

But I am still getting the symbol lookup error. Any suggestions?

utk50 gravatar image utk50  ( 2020-08-18 18:15:06 -0500 )edit

Did you find any solution yet?

ranjeet gravatar image ranjeet  ( 2021-01-31 02:55:47 -0500 )edit

Question Tools



Asked: 2018-02-12 17:23:10 -0500

Seen: 4,699 times

Last updated: Feb 13 '18