Ask Your Question
0

GSCAM over ubuntu server

asked 2012-02-22 05:01:22 -0500

Hi all..

i'm trying to add a web cam to my pionner at-e robot, i have ubuntu 10.4 server version (no x systems), i have already installed the required components of GSCAM and the compilation gives no errors or warnings

i export the environment variable

$ export GSCAM_CONFIG="v4l2src device=/dev/video1 ! video/x-raw-rgb ! ffmpegcolorspace"

then i run the node

$ rosrun gscam gscam

but i get the next error:

Gstreamer Version: GStreamer 0.10.28 no element "v4l2src"

any ideas? is it possible to run gscam on a server edition of ubuntu?

thanks a lot

Mario

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2012-02-22 05:15:49 -0500

John Hoare gravatar image

You need to have the gstreamer0.10-plugins-good package installed. The v4l2src element is located in the "good" plugins http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-good-plugins/html/gst-plugins-good-plugins-v4l2src.html

edit flag offensive delete link more

Comments

Thanks a lot... that solved my the problem... i had installed only the gstreamer0.10-plugins :)

Mario Garzon gravatar image Mario Garzon  ( 2012-02-22 08:05:19 -0500 )edit
0

answered 2012-02-24 00:43:24 -0500

The manual is just for the gstreamer0.10-plugins-good library, which is used by gscam to publish the output of the webcam over ROS, in a server edition of ubuntu that library is not included so you have to manually install it usign

sudo apt-get install gstreamer0.10-plugins-good

hope that answers your question..

Mario

edit flag offensive delete link more
0

answered 2012-02-23 16:53:51 -0500

Parisa gravatar image

I also have this problem. But I am not familiar more with ubuntu and I dont understand anything from this manual http://gstreamer.freedesktop.org/data/doc/gstreamer/head/gst-plugins-good-plugins/html/gst-plugins-good-plugins-v4l2src.html Can I ask you to explain it for me?

Many thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-22 05:01:22 -0500

Seen: 1,558 times

Last updated: Feb 24 '12