Ask Your Question
1

rosrun gscam on ubuntu 11.10

asked 2012-02-24 05:47:22 -0600

Parisa gravatar image

I am using ROS electric on Ubuntu 11.10. I have installed gscam and its rosmake was successfully. For running gscam, as in the gscam wiki is mentioned, I did these steps:

roscd gscam cd bin export GSCAM_CONFIG="v4l2src device=/dev/video2 ! video/x-raw-rgb ! ffmpegcolorspace" rosrun gscam gscam

but it says:

Gstreamer Version: GStreamer 0.10.35 Failed to PAUSE.

In the gscam wiki is mentioned that If you see a message about a "failure to PAUSE" or something similar, the most likely cause is a permission issue with the available video devices.

Anybody can help me for this problem.

Many thanks!

Parisa.

edit retag flag offensive close merge delete

Comments

just change export GSCAM_CONFIG="v4l2src device=/dev/video2 ! video/x-raw-rgb ! ffmpegcolorspace" with export GSCAM_CONFIG="v4l2src device=/dev/video0 ! video/x-raw-rgb ! ffmpegcolorspace"

nandhini gravatar imagenandhini ( 2012-03-26 02:17:31 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-02-25 16:26:43 -0600

tjay gravatar image

I assume you've already tried:

sudo chmod a+rw /dev/video2

or similar to no effect?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-24 05:47:22 -0600

Seen: 508 times

Last updated: Feb 24 '12