Ask Your Question

Phantomx Pincher working space error

asked 2018-01-31 06:17:49 -0500

huseyin_26 gravatar image

updated 2018-01-31 07:00:08 -0500

Hi guys , i am trying to control phantomx pincher robot arm. I use this source . when i run this code roslaunch pxpincher_launch pxp.launch it gives that message :

ı have a real robot arm and also i can see robots movement in rviz . but i am also moved the arm by hand. Also i can control the robot arm with arbotix_gui.

Serial port opened
[ INFO] [1517400955.298249656]: Initializing...
[ INFO] [1517400955.810258295]: Initializing successfull...
[ INFO] [1517400955.947770546]: Arm controller loaded
[ INFO] [1517400956.002605250]: Gripper controller loaded
[ INFO] [1517400956.019290065]: Speed forwarding controller loaded
[ INFO] [1517400956.

025261949]: PxPincher hardware node started.
    [ERROR] [1517400956.045893352]: The robot is currently outside its working space. The servos are relaxed now, please catch the falling robot.

[ERROR] [1517400956.045970538]: Please move the robot to its working space manually and restart the node or use the services to unrelax servos.
[ INFO] [1517400956.046274540]: Arm controller and gripper controller started
edit retag flag offensive close merge delete



This is a very specific question about a that specific package. I feel you'll have a higher chance of getting an answer by asking it on the issue tracker of the package.

Looking at the repository it appears @croesmann was one of the main authors, so perhaps he knows.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-31 06:56:04 -0500 )edit

That time i hope he will help me. I will edit my question .

huseyin_26 gravatar image huseyin_26  ( 2018-01-31 06:58:49 -0500 )edit

Btw: this doesn't seem like a real error. The message just tells you that according to the ROS settings (urdf, yaml file, something else) some (or all) of the joints are outside their limits. You should put it back inside the limits. Things will probably start working then.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-31 07:02:42 -0500 )edit

Yes you can be right but i change its position again also ı chaned its up and low limit but something isn't changed. I am really confuse about it.

huseyin_26 gravatar image huseyin_26  ( 2018-01-31 07:54:14 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2018-02-01 01:27:30 -0500

croesmann gravatar image

This could happen if you have assembled the pxpincher with one or more servo motors rotated by 180 degrees. In that case, the robot is probably out of the workspace w.r.t. the current configuration. You might try to check the joint limits in the urdf/yaml file (and maybeif there is also any related stuff in the code which would be affected by a 180 degree changed orientation, I don't remember right now). The dynamixel servos do not operate in full 360 degrees, this could be a potential issue here. Otherwise you could also reassemble the robot.

Please also check the function in which the error is produced. Maybe we can add further information to tell the user which servo is out of bounds. I would be happy to accept any pull-request ;-).

edit flag offensive delete link more

answered 2019-01-23 00:50:38 -0500

z1huo gravatar image

You can manually fold your robot, and make sure your robot is "steadily" on the ground: The head of the robot fully touches the ground, so that the robot does not "fall over".

Even though in reality your robot might not fall over because its center of mass is within its feet area, the yaml file suggests you to lie everything on the ground so that it can make sure it will not fall.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-01-31 06:17:49 -0500

Seen: 201 times

Last updated: Jan 23 '19