ROS Lunar install on Debian Jessie fails -- GPG key missing?

asked 2018-01-23 17:56:04 -0600

skotzko gravatar image

updated 2018-01-24 12:57:12 -0600

gvdhoorn gravatar image

I am trying to install ROS on Debian:jessie following the instructions here.

I pinged the server ha.pool.sks-keyservers.net to verify it was up. It was. Then I searched the server for the key specified (key "421C365BD9FF1F717815A3895523BAEEB01FA116") in the install docs, and it returned "No result found".

Was the key removed from the server? Is there a new key that should be used instead, and the install docs didn't get updated?


Edit: Here are the messages I get:

gpg: requesting key B01FA116 from hkp server ha.pool.sks-keyservers.net
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error
edit retag flag offensive close merge delete

Comments

Can you please show us the exact error message that you received? From your description it's hard to know what is going on exactly.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-24 03:16:42 -0600 )edit

See also #q264654 and #q275824 btw.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-24 03:17:26 -0600 )edit

I just tried the command from the installation tutorial you link to on a clean Debian Jessie and it worked. Could be something transient?

gvdhoorn gravatar image gvdhoorn  ( 2018-01-24 13:00:55 -0600 )edit