Ask Your Question
0

Ros Canopen PositionJointInterface working with mode 3?

asked 2018-01-18 19:32:11 -0600

leo gravatar image

updated 2018-01-18 22:37:53 -0600

Hi, I try to control my robot arm by ros canopen but the driver do not have Interpolated Position Mode which is mode 7. I follow the canopen_test_utils example and it use mode 3 for position controller, but I got error as

[ERROR] [1516324623.132823131]: hardware_interface::PositionJointInterface cannot be provided in mode 3
[ERROR] [1516324623.132886958]: Could not switch controllers. The hardware interface combination for the requested controllers is unfeasible.
[ERROR] [WallTime: 1516324623.133238] Failed to start controllers: joint_trajectory_pid_controller

So I just wonder can I use Profiled Velocity Mode for PositionJointInterface ?

edit retag flag offensive close merge delete

Comments

Why my question is not showed on the question list and it says This post is awaiting moderation?

leo gravatar imageleo ( 2018-01-18 19:37:44 -0600 )edit

I think the new users need to be approved as part of spam user prevention. Now you're approved :)

130s gravatar image130s ( 2018-01-18 20:52:35 -0600 )edit

Ok, I see, Thanks for ur help.

leo gravatar imageleo ( 2018-01-18 22:35:37 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-02-20 11:30:57 -0600

Mathias Lüdtke gravatar image

The Profiled velocity mode does not offer hardware_interface::PositionJointInterface, but hardware_interface::VelocityJointInterface.

That's why you have to use velocity_controllers/JointTrajectoryController with proper PID settings.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-01-18 19:32:11 -0600

Seen: 99 times

Last updated: Feb 20 '18