Ask Your Question
0

rtabmap with stereo images

asked 2018-01-16 05:34:11 -0500

zahra.kh gravatar image

hi, i used this file link text for create map and localization by stereo images. but when i used parameter (rviz:=true), rtabmapviz and rviz simultaneous run and this error is created: [pcl::VoxelGrid::applyFilter] Leaf size is too small for the input dataset. Integer indices would overflow.

please help me

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-01-17 11:17:11 -0500

matlabbe gravatar image

The warning was coming from rtabmap_ros/points_xyzrgb nodelet, caused by the voxel_size parameter which was set too small for the stereo point clouds. This is fixed in this commit where voxel_size is now disabled by default.

cheers

edit flag offensive delete link more

Comments

how can i solved this problem? Should I update rtabmap_ros package?

zahra.kh gravatar image zahra.kh  ( 2018-01-18 01:57:20 -0500 )edit

You can manually make the change in your installed rtabmap.launch, or copy rtabmap.launch to another location and modify it. No rebuild from source is required as it is a change in a launch file. You can also not subscribe to voxel_cloud in RVIZ, then the warning will disappear.

matlabbe gravatar image matlabbe  ( 2018-01-18 09:11:03 -0500 )edit

thanks, matlabbe

zahra.kh gravatar image zahra.kh  ( 2018-01-18 12:47:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-16 05:34:11 -0500

Seen: 375 times

Last updated: Jan 17 '18