Ask Your Question
0

rosnode ping error

asked 2012-02-19 02:42:55 -0500

cg gravatar image

Hello to all,

I am trying to follow the tutorials on ROS wiki.

I came across an error concerning the rosnode ping command.

I am getting the following error:

root@ubuntu:~# rosnode ping my_turtle rosnode: node is [/my_turtle] pinging /my_turtle with a timeout of 3.0s Traceback (most recent call last): File "/opt/ros/electric/ros/bin/rosnode", line 35, in <module> rosnode.rosnodemain() File "/opt/ros/electric/stacks/ros_comm/tools/rosnode/src/rosnode.py", line 713, in rosnodemain sys.exit(_rosnode_cmd_ping(argv) or 0) File "/opt/ros/electric/stacks/ros_comm/tools/rosnode/src/rosnode.py", line 681, in _rosnode_cmd_ping rosnode_ping(node_name, verbose=True, max_count=options.ping_count) File "/opt/ros/electric/stacks/ros_comm/tools/rosnode/src/rosnode.py", line 292, in rosnode_ping errnum, msg = e ValueError: need more than 1 value to unpack root@ubuntu:~#

Any clues?

Thanks.

edit retag flag offensive close merge delete

Comments

Sorry, I have no clue, but it usually helps people if you tell them what version Ubuntu and ROS you are using.

Kevin gravatar image Kevin  ( 2012-02-19 03:36:44 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-02-19 23:58:46 -0500

cg gravatar image

Thanks Kevin,

I had finally worked it out, my localhost was pointing to a static IP I had set in the past, that was different than the one I needed.

I changed the IP settings and it worked.

Regards,

cg

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-19 02:42:55 -0500

Seen: 422 times

Last updated: Feb 19 '12