move_base problem: i ran move_base node to accept the /scan topic from rplidar node, but the move_base node wants the /CloudPoint type rather than /LaserScan type.

asked 2018-01-02 21:28:55 -0500

Tider gravatar image

updated 2018-01-02 23:03:05 -0500

the error info is shown below:

Client [/move_base] wants  topic /scan to have datatype/md5sum [sensor_msgs/PointCloud/...], but our version has [sensor_msgs/LaserScan/...].Dropping Connection.

I think i have configured the observation_source in the costmap_common_params.yaml file as below, but it still shows that move_base node wants the PointCloud type of topic /scan. The topic /scan is published as LaserScan type. Does anyone have ideas on this problem? with great thanks.

obstacle_range: 2.5
raytrace_range: 3.0
footprint: [[-0.16,0],[0,0.16],[0.16,0]]
inflation_radius: 0.55
observation_sources: scan
scan: {datatype: LaserScan, topic: /scan, marking: true, clearing: true, expected_update_rate: 0}

and the other config file for move_base is shown as below:


  global_frame: map
  robot_base_frame: base_link
  update_frequency: 5.0
  static_map: false


  global_frame: odom
  robot_base_frame: base_link
  update_frequency: 5.0
  publish_frequency: 2.0
  static_map: false
  rolling_window: true
  width: 6.0
  width: 6.0
  resolution: 0.05


  max_vel_x: 0.45
  min_vel_x: 0.1
  max_vel_theta: 1.0
  min_in_place_vel_theta: 0.4

  acc_lim_theta: 3.2
  acc_lim_x: 2.5
  acc_lim_y: 2.5

  holonomic_robot: false
edit retag flag offensive close merge delete


Please update your question with a copy and paste of the error.

jayess gravatar image jayess  ( 2018-01-02 22:44:38 -0500 )edit

Sees fine to me, actually. Are you sure you are launching/including the correct files? If you can make it public, put the Launch/config files on github, so we can try to reproduce...

mgruhler gravatar image mgruhler  ( 2018-01-04 09:21:37 -0500 )edit

This was quite strange. When I first tried the setting above, it failed with the problem above. Then I did several kinds of revising according to my net searching, but none of them worked. So i recovered it back to the origin one, what's awkard is that it just works then. Thanks for minding.

Tider gravatar image Tider  ( 2018-01-08 21:08:37 -0500 )edit

@Tider happy it works. Maybe consider either answering yourself or closing this question, as you see fit...

mgruhler gravatar image mgruhler  ( 2018-01-09 00:50:02 -0500 )edit