ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Cannot initialize this controller, because it failed to be constructed.

asked 2018-01-02 07:28:29 -0600

Fiddle gravatar image

updated 2018-01-03 05:11:42 -0600

Hi, I am trying to launch my environment from another catkin workspace, but when I run the same commands I get different results, although I've built it the same (although this catkin workspace also contains different files, because I got it from installing the gym-gazebo). The other files don't look like they invade the space of my gripper file, is there a way to compare between two workspaces?

When i run my files, the console logs:

[ INFO] [1514898661.365225923, 0.070000000]: Physics dynamic reconfigure ready.
[INFO] [1514898661.583828, 0.285000]: Controller Spawner: Waiting for service controller_manager/switch_controller
[INFO] [1514898661.586144, 0.286000]: Controller Spawner: Waiting for service controller_manager/unload_controller
[INFO] [1514898661.588326, 0.286000]: Loading controller: joint_trajectory_controller
[ERROR] [1514898661.602523595, 0.296000000]: Cannot initialize this controller because it failed to be constructed
*** Error in `gzserver': munmap_chunk(): invalid pointer: 0x00007f9e94b588d8 ***
======= Backtrace: =========
======= Memory map: ========

Here, a lot of stuff pointing to different files, don't know if this is relevant, but at the end

Traceback (most recent call last):
  File "/home/user/smart_robotics_v2/gym-gazebo/gym_gazebo/envs/installation/catkin_ws/src/ros_control/controller_manager/scripts/spawner", line 212, in <module>
    if __name__ == '__main__': main()
  File "/home/user/smart_robotics_v2/gym-gazebo/gym_gazebo/envs/installation/catkin_ws/src/ros_control/controller_manager/scripts/spawner", line 190, in main
    resp = load_controller(name)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rospy/impl/", line 435, in __call__
    return*args, **kwds)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rospy/impl/", line 525, in call
    raise ServiceException("transport error completing service call: %s"%(str(e)))
rospy.service.ServiceException: transport error completing service call: unable to receive data from sender, check sender's logs for details
[INFO] [1514898661.737440, 0.317000]: Shutting down spawner. Stopping and ...
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2018-01-03 09:34:31 -0600

Fiddle gravatar image

Ok, so I figured out the answer, albeit it was pretty tricky. I noticed, that the gazego_ros_pkgs and ros_control were in different versions than in the official repository, so I deleted and reinstalled them according to the docs, now everything works again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-01-02 07:28:29 -0600

Seen: 719 times

Last updated: Jan 03 '18