Ask Your Question
0

GPS Ublox node can't go in FIX mode

asked 2017-12-21 13:40:19 -0500

Marcus Barnet gravatar image

updated 2017-12-21 13:41:00 -0500

Hi to all,

I'm having problems with the ublox node. I'm using the C94-M8P evaluation board which provides two boards: one for the rover and one for the base.

I'm able to receive RTK corrections when I use it under Ubuntu, but as soon as I run the ublox node, the LED which indicates the RTK corrections blinks only sometimes and so it seems that it loses the radio link or it is not able to elaborate the RTK corrections.

If I shut down the node, then the LED for the RTK corrections stays steady and the corrections are always received.

Why this happens? How can I fix this?

I launch the node in this way: roslaunch ublox_gps ublox_device.launch

This is the launch file:

  <?xml version="1.0" encoding="UTF-8"?>

<launch>
  <arg name="ublox_gps" />
  <arg name="param_file_name" doc="c94_m8p_rover.yaml" />
  <arg name="output" default="screen" />
  <arg name="respawn" default="true" />
  <arg name="respawn_delay" default="30" />
  <arg name="clear_params" default="true" />

  <node pkg="ublox_gps" type="ublox_gps" name="ublox_gps"
        output="$(arg output)" 
        clear_params="$(arg clear_params)"
        respawn="$(arg respawn)" 
        respawn_delay="$(arg respawn_delay)">
    <rosparam command="load" 
              file="$(find ublox_gps)/config/c94_m8p_rover.yaml" />
  </node>
</launch>

This is my configuration file:

# Configuration Settings for C94-M8P device

debug: 1                    # Range 0-4 (0 means no debug statements will print)

save:
  mask: 3103                # Save I/O, Message, INF Message, Nav, Receiver 
                            # Manager, Antenna, and Logging Configuration
  device: 4                 # Save to EEPROM

device: /dev/ttyACM0
frame_id: gps
rate: 1                     # in Hz
nav_rate: 4                 # [# of measurement cycles], recommended 1 Hz, may 
                            # be either 5 Hz (Dual constellation) or 
                            # 8 Hz (GPS only)
dynamic_model: pedestrian   # pedestrian o automotive 
                            # Max Alt: 50km
                            # Max Horizontal Velocity: 250 m/s, 
                            # Max Vertical Velocity: 100 m/s
fix_mode: auto
enable_ppp: false           # Not supported by C94-M8P
dr_limit: 0

# TMODE3 Config
tmode3: 0                   # Survey-In Mode
sv_in:
  reset: false              # True: disables and re-enables survey-in (resets)
                            # False: Disables survey-in only if TMODE3 is  
                            # disabled
  min_dur: 300              # Survey-In Minimum Duration [s]
  acc_lim: 3.0              # Survey-In Accuracy Limit [m]

uart1:
  baudrate: 19200           # C94-M8P specific
  in: 32                    # RTCM 3
  out: 0                    # No UART out for rover

gnss:
  glonass: true             # Supported by C94-M8P
  beidou: false             # Supported by C94-M8P
  qzss: false               # Supported by C94-M8P

dgnss_mode: 3               # Fixed mode

inf: 
  all: true                   # Whether to display all INF messages in console

# Enable u-blox message publishers
publish:
  all: true
  aid:
    hui: false

  nav:
    posecef: false
edit retag flag offensive close merge delete

Comments

If you haven't solved the issue with the M8P, you might want to consider the new product ZED-F9P, that solves many of the limitations of M8P. There's also a ready to use evaluation board.

ardusimple gravatar imageardusimple ( 2018-10-28 11:16:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-15 02:21:45 -0500

blasalat gravatar image

I had similar problems with the ublox node. I configured my ublox devices manually with u-center and used the nmea-navsat-driver (make sure to configure the ublox board to send nmea-gga messages)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2017-12-21 13:40:19 -0500

Seen: 879 times

Last updated: Oct 28 '18