ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

[Solved](rosjava)catkin_create_rosjava_pkg: command not found

asked 2017-12-06 06:21:49 -0500

ramekabi gravatar image

updated 2017-12-06 07:29:45 -0500
I tried this.

ubuntu@ubuntu:~$ mkdir -p src
ubuntu@ubuntu:~$ cd src
ubuntu@ubuntu:~/src$ catkin_create_rosjava_pkg rosjava_catkin_package_a
catkin_create_rosjava_pkg: command not found
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-12-06 06:41:26 -0500

jubeira gravatar image

Did you source rosjava_build_tools before running that?

If you followed the instructions to install rosjava from source ( ), you need to source the workspace: source ~/rosjava/devel/setup.bash

Only after doing that you can start using those command line tools.

edit flag offensive delete link more


Thank you. Solved.

ramekabi gravatar image ramekabi  ( 2017-12-06 06:51:18 -0500 )edit

Great! Please mark the answer as the accepted one so others can make use of it.

jubeira gravatar image jubeira  ( 2017-12-06 06:52:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-12-06 06:21:49 -0500

Seen: 400 times

Last updated: Dec 06 '17