Ask Your Question
0

Problems Connecting to serial Port :/dev/ACM0

asked 2017-11-24 17:07:22 -0600

pacifickid9 gravatar image

updated 2017-11-25 17:28:29 -0600

I've been stuck on this for a while my problem is I cant access GPS data for a ublox node. I am connecting to a Raspberry pi 3 that is running a RPI 2 Snappy Image. I am connecting to the PI through a SSH on a ubuntu 14.04 laptop.

I am running the following command and getting this error: (updated output with correct port spelling)

    ubuntu@ubuntu:~$ roslaunch ublox_gps ublox_device.launch 
... logging to /home/ubuntu/.ros/log/cefae814-d237-11e7-8ade-b827ebffc577/roslaunch-ubuntu-1799.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.2.55:35153/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.7
 * /ublox_gps/debug: 1
 * /ublox_gps/device: /dev/ttyAMC0
 * /ublox_gps/dgnss_mode: 3
 * /ublox_gps/dr_limit: 0
 * /ublox_gps/dynamic_model: portable
 * /ublox_gps/enable_ppp: False
 * /ublox_gps/fix_mode: auto
 * /ublox_gps/frame_id: gps
 * /ublox_gps/gnss/beidou: False
 * /ublox_gps/gnss/glonass: True
 * /ublox_gps/gnss/qzss: False
 * /ublox_gps/inf/all: True
 * /ublox_gps/nav_rate: 4
 * /ublox_gps/publish/aid/hui: False
 * /ublox_gps/publish/all: True
 * /ublox_gps/publish/nav/posecef: False
 * /ublox_gps/rate: 4
 * /ublox_gps/save/device: 4
 * /ublox_gps/save/mask: 3103
 * /ublox_gps/uart1/baudrate: 19200
 * /ublox_gps/uart1/in: 32
 * /ublox_gps/uart1/out: 0

NODES
  /
    ublox_gps (ublox_gps/ublox_gps)

auto-starting new master
process[master]: started with pid [1813]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to cefae814-d237-11e7-8ade-b827ebffc577
process[rosout-1]: started with pid [1826]
started core service [/rosout]
process[ublox_gps-2]: started with pid [1829]
terminate called after throwing an instance of 'std::runtime_error'
  what():  U-Blox: Could not open serial port :/dev/ttyAMC0 open: No such file or directory
[ublox_gps-2] process has died [pid 1829, exit code -6, cmd /home/ubuntu/catkin_ws/devel/lib/ublox_gps/ublox_gps __name:=ublox_gps __log:=/home/ubuntu/.ros/log/cefae814-d237-11e7-8ade-b827ebffc577/ublox_gps-2.log].
log file: /home/ubuntu/.ros/log/cefae814-d237-11e7-8ade-b827ebffc577/ublox_gps-2*.log
^C[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I checked that the port was correct by using

cat /dev/ttyACM0

it outputted my GPS Data that I was looking for, I assumed that I was permission were off so I did the command

groups

this is the output

ubuntu adm dialout cdrom floppy sudo audio dip video plugdev netdev lxd

it says I'm in the dialout group, so i assumed my permissions were fine. when I do

ls -la /dev/ttyACM0
crw-rw-rw- 1 root dialout 166, 0 Feb 11  2016 /dev/ttyACM0

So there is a problem with my # after dialout its should be 666 right? I tried using

sudo chmod 666 /dev/ttyAMC0

No change to the permissions.

Does anyone know how to change the dialout 166 problem? thanks - or any other solutions that would allow me to open the port or read the GPS Data.

edit retag flag offensive close merge delete

Comments

The error message said there was no file /dev/ACM0, and then you start to explain the effort put into /dev/ttyAMC0. They're not the same thing.

billy gravatar imagebilly ( 2017-11-24 21:05:18 -0600 )edit

Sorry I miss typed into the launch file parameters, but i retested it with /dev/ttyACM0 and got the same result.

pacifickid9 gravatar imagepacifickid9 ( 2017-11-24 21:34:42 -0600 )edit

I think i spelled it wrong I got another error so this one must have been solved thanks guys ill be more careful next time!

pacifickid9 gravatar imagepacifickid9 ( 2017-11-25 17:30:25 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-11-25 02:49:42 -0600

gvdhoorn gravatar image

updated 2017-11-25 02:50:34 -0600

but i retested it with /dev/ttyACM0

can you please check again? It's ttyAMC0, not ttyACM0.

After you've changed the launch file / parameters, update your original post to show us the output.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-24 17:07:22 -0600

Seen: 1,812 times

Last updated: Nov 25 '17