Ask Your Question
1

p2os setup failed... for Hydro

asked 2014-12-01 18:28:20 -0500

updated 2014-12-04 17:54:01 -0500

I've been working through the p2os-vanderbilt setup tutorial and have been having many issues. I am currently using Ubuntu 12.04 with ROS Hydro and a Pioneer 3-DX connected to my SlimPro via serial comm port.

I have successfully installed and compiled the p2os and the pr2 controllers packages:

sudo apt-get install ros-hydro-p2os-driver ros-hydro-p2os-teleop ros-hydro-p2os-launch ros-hydro-p2os-urdf
sudo apt-get install ros-groovy-pr2-controllers ros-groovy-joystick-drivers
cd ~/catkin_ws/src && git clone https://github.com/allenh1/p2os.git  /*note different from tutorial*/
git clone https://github.com/allenh1/vanderbilt-ros-pkg.git          /*note different from tutorial*/
source ../devel/setup.bash
cd ~/catkin_ws
catkin_make

When I try:

rosrun p2os_driver p2os_driver

so I can then enable the motor, I get an error:

[ INFO] [1417478313.806461148]: using serial port: [/dev/ttyS0]
[ INFO] [1417478313.835717295]: P2OS connection opening serial port /dev/ttyS0...
[ERROR] [1417478313.835785839]: P2OS::Setup():open():
[ERROR] [1417478313.835822762]: p2os setup failed...

I went into ~/catkin_ws/src/p2os/p2os_driver/include/p2os_driver/robot_param.h and changed the DEFAULT_P2OS_PORT "/dev/ttyS0" to DEFAULT_P2OS_PORT "/dev/tty0" and changed the ros parameter with:

rosparam set /p2os/port /dev/tty0

and I got the same issue as before (except the error read "tty0" instead). I've tried enabling the motor before and after running the p2os_driver.

Your help in this matter is greatly appreciated. Thanks.

On a side note, does anyone know where I can find the p2os_dashboard for Hydro? Thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-12-03 19:18:19 -0500

updated 2015-03-23 09:17:42 -0500

I've been emailing back and forth with Hunter Allen of Vanderbilt.

I simply had to use this command:

sudo chmod 777 -R /dev/ttyS0

and it began working.

Additionally, if you are using a USB connection, use the following:

sudo chmod 777 -R /dev/ttyUSB0

I have tested it out successfully with the C++ Velocity Node from the p2os-vanderbilt tutorials (with a few minor adjustments).

Thanks for all your help y'all.

edit flag offensive delete link more

Comments

If this solves your problem, please mark this answer as correct.

BennyRe gravatar imageBennyRe ( 2014-12-04 00:38:40 -0500 )edit

Sorry. You must have greater than 25 points to mark your own answer as correct...I will once I get there.

sealguy77 gravatar imagesealguy77 ( 2014-12-04 01:10:06 -0500 )edit
1

Now you should be fine.

BennyRe gravatar imageBennyRe ( 2014-12-04 01:31:35 -0500 )edit
0

answered 2014-12-02 06:34:22 -0500

BennyRe gravatar image

/dev/tty0 is something completely else than the serial port of your computer. Try ttyS1, ttyS2,... these are the serial ports.

edit flag offensive delete link more

Comments

Do you use an USB-to-serial converter or a native serial interface?

BennyRe gravatar imageBennyRe ( 2014-12-03 01:06:42 -0500 )edit

Native serial interface between the P3-DX and my SlimPro.

sealguy77 gravatar imagesealguy77 ( 2014-12-03 03:57:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-01 18:28:20 -0500

Seen: 653 times

Last updated: Mar 23 '15