ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Unable to communicate with master with roscore running

asked 2017-10-30 13:18:55 -0500

tayagrey6 gravatar image

Hi, I am trying to subscribe to a node I launched on a raspberry pi on my laptop. I am able to SSH into the raspberry pi to launch the node (the problem is not that roscore isn't running because it is), but when I open another terminal and run rostopic list, the cursor blinks for a while before I get an "Unable to communicate with master" error. Both of my machines have the same ROS_MASTER_URI, which is http://cameraduckie.local:11311 . This hostname is the one that I ssh into from my laptop to launch the first node. I am very confused because the two machines can ping each other but the laptop cannot communicate with master--any insight would be greatly appreciated. Thanks, Taylor

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-10-31 01:52:33 -0500

Oded gravatar image

It sounds that you didn't configure your ROS_IP variable.

Let's assume that the IP of your master (where the roscore is running - the raspberry pi in your case) is, so you will have to run


export ROS_IP=

And assume on the slave computer the IP is, you will have to run


export ROS_IP=

After that you should have ROS connectivity

edit flag offensive delete link more


Hi Oded, I tried this but unfortunately it didn't work either--I receive the same error as before. I had this whole configuration working via ethernet before, but then it stopped working when I switched over to wifi--if that helps at all. Thank you for your response!

tayagrey6 gravatar image tayagrey6  ( 2017-11-01 12:16:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-10-30 13:18:55 -0500

Seen: 3,404 times

Last updated: Oct 31 '17