Problem with Roscore : Ros master URI is not defined

asked 2017-10-26 13:52:33 -0600

Baumboon gravatar image

updated 2017-10-26 16:06:28 -0600

Hello Guys,

First of all my OS is Ubuntu 16.04 with Ros Kinetic and Gazebo 7.0. I installed that with full desktop install.

i followed the tutorial on :

http://gazebosim.org/tutorials?cat=gu...

everything works fine until i got to the ros part. I worked with ros before with turtlebot package and there everything works fine too...

when i type in :

cd ~/velodyne_plugin/build
source /opt/ros/kinetic/setup.bash
gazebo ../velodyne.world

i got :

[FATAL] [1509043732.797014978]: ROS_MASTER_URI is not defined in the environment. Either type the following or (preferrably) add this to your ~/.bashrc file in order set up your local machine as a ROS master:

export ROS_MASTER_URI=http://localhost:11311

then, type 'roscore' in another shell to actually launch the master program.

when i echo ros_master_uri i got the local host address... i have no idea what i am doing wrong

edit retag flag offensive close merge delete

Comments

Please don't add things like "plz help me": we already know you want us to help you as otherwise you would not be posting here ..

gvdhoorn gravatar image gvdhoorn  ( 2017-10-26 14:07:24 -0600 )edit

This reminds me of #q274044. Can you check that question and see whether you're seeing the same things?

Can you please add what OS this is, which version, how you installed your OS, which version of ROS and how you installed that.

gvdhoorn gravatar image gvdhoorn  ( 2017-10-26 14:08:37 -0600 )edit