Ar.Drone 2.0 parameter settings, and missing services

asked 2017-09-26 08:15:52 -0600

Steve_RosUsr gravatar image

Hy Everyone! I am writing my thesis in the university, which is about AR.Drone controlling via ROS. I am using Ros indigo igloo on a Ubuntu 14.04 virtual machine. I have read the latest documentation for the ardrone_autonomy package (link: http://ardrone-autonomy.readthedocs.i... ), but when i run the node, these parameters are not displayed.

How can I be able to set those parameters? I have to use the drone indoor, and i want to set every parameter to minimum in order to avoid damages in the device and in the people around me during work :D(for example: altitude, max vertical speed, rotation speed max, ...).

My other problem is that the documentation mentions that there is a service - called /ardrone/imu/calibrate - what can calibrate the imu sensor on the device. But I do not see this service.

What can I do? Please help me...

Thanks for your help in advance!

Steve

edit retag flag offensive close merge delete

Comments

What launch file are you using? What have you tried to view the parameters? What have you tried to view the service? Have you looked at the source code (hint: you can view many of the parameters there).

jayess gravatar imagejayess ( 2017-10-02 13:42:30 -0600 )edit

i did not use any launch file, just rosrun ardrone_autonomy ardrone_driver command.

Steve_RosUsr gravatar imageSteve_RosUsr ( 2017-10-04 05:37:38 -0600 )edit

What did you do to view the parameters (rosparam list)? What did you do to view the service (rosservice list)?

jayess gravatar imagejayess ( 2017-10-04 09:52:54 -0600 )edit