Ask Your Question
0

How do I properly use multimarker in an xml file?

asked 2017-09-22 07:19:28 -0600

phi_abs gravatar image

I am trying to detect three AR trackers with the ar_track_alvar package link ar_track_alvar package. The three trackers should be detected as a bundle. My xml file which describes the markers looks as follows:

<multimarker markers="3">

<marker index="0" status="1">
  <corner x="-3.45" y="-3.45" z="0" />
  <corner x="3.45" y="-3.45" z="0" />
  <corner x="3.45" y="3.45" z="0" />
  <corner x="-3.45" y="3.45" z="0" />
</marker>

<marker index="1" status="1">
  <corner x="-3.45" y="-16.85" z="0" />
  <corner x="3.45" y="-16.85" z="0" />
  <corner x="3.45" y="-9.95" z="0" />
  <corner x="-3.45" y="-9.95" z="0" />
</marker>

<marker index="2" status="1">
  <corner x="21.15" y="-16.85" z="0" />
  <corner x="28.05" y="-16.85" z="0" />
  <corner x="28.05" y="-9.95" z="0" />
  <corner x="21.15" y="-9.95" z="0" />
</marker>

</multimarker>

  • As far as I understood the first marker has to have index 0. For the other markers the index does not matter, right?
  • What does the status mean? What arguments are valid?
  • Sometimes I get the following error: ERROR InferCorners: "ar_marker_0" passed to lookupTransform argument source_frame does not exist. Sometimes it is also another marker number. How can I avoid this error or what is the reason for it?
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-18 09:06:15 -0600

This is an old one, but I've just been working out the answers to a few of these questions myself so I thought I'd add them here. I'll answer your three questions separately.

  1. The first marker index in the bundle XML file can be any marker on you object, it can but doesn't have to be marker zero. The other marker indices must correspond their the appropriate marker number used.
  2. Status was a bit of mystery until I dug into the source code, it seems there is some support for extra corner features on the objects as well the marker tags but I haven't attempted to get this working yet. From experimentation we've had it working fine with a status of 1 or 2.
  3. I can't help you with this one I'm afraid, we've not experienced this error on our setup.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-09-22 07:19:28 -0600

Seen: 98 times

Last updated: Jan 18 '18