Ask Your Question
0

Error linking libccd

asked 2017-08-17 23:06:17 -0500

jwatson_utah_edu gravatar image

I have a problem compiling a project that uses FCL and libccd, both of which are compiled from source and make installed. All the the libraries seem to be in the proper place, but I still get the following error:

/usr/bin/ld: CMakeFiles/test_01_mrkr.dir/src/test_01_mrkr.cpp.o: undefined reference to symbol 'ccd_vec3_origin'
/usr/local/lib/libccd.so.2: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
geo_devel/CMakeFiles/test_01_mrkr.dir/build.make:170: recipe for target '/home/jwatson/asm_seq_plan_3d/devel/lib/geo_devel/test_01_mrkr' failed
make[2]: *** [/home/jwatson/asm_seq_plan_3d/devel/lib/geo_devel/test_01_mrkr] Error 1
CMakeFiles/Makefile2:528: recipe for target 'geo_devel/CMakeFiles/test_01_mrkr.dir/all' failed
make[1]: *** [geo_devel/CMakeFiles/test_01_mrkr.dir/all] Error 2
Makefile:138: recipe for target 'all' failed
make: *** [all] Error 2
  • Ubuntu 16.04
  • ROS Kinetic
  • FCL Version: 0.5.0-271-gf6a73c7 , Commit: f6a73c7
  • libccd Version: v2.0-37-g64f02f7 , Commit: 64f02f741ac94fccd0fb660a5bffcbe6d01d9939

I should also add that I took care to remove the ROS version of FCL.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-03-09 15:58:05 -0500

duck-development gravatar image

you may forget to add the lib in the link section of the binary bild. because you are able to compile bot not to Link.

with c++ always the first error metters.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-08-17 23:06:17 -0500

Seen: 296 times

Last updated: Mar 09 '20