Ask Your Question
0

FCL Linking with catkin build

asked 2014-06-09 23:57:38 -0600

Dave Coleman gravatar image

updated 2014-06-10 00:01:11 -0600

I've just switched from catkin_make_isolated to catkin tools for building ROS from source. I added the --install command but I'm getting errors when building MoveIt! in a different workspace after sourcing the ROS installed from source workspace:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
LIBFCL_LIBRARIES_FULL
    linked by target "moveit_collision_detection_fcl" in directory /home/dave/ros/ws_moveit/src/moveit_core/collision_detection_fcl

-- Configuring incomplete, errors occurred!

There is something wrong with FCL or my environment, but I am not sure what to do. I have already built several other workspaces on top of the ROS-installed-from-source one, so it seems to mostly be working. Thanks!

--- EDIT ---

Perhaps this might be useful: there were some issues with FCL on this ROS Answer and there was a fix in moveit_core as noted in the changelog for 0.5.7

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-10 00:16:09 -0600

Dave Coleman gravatar image

Okay, I figured out my mistake. Although I (later) added the --install argument, I had still forgotten to source the /install/setup.bash but instead was only sourcing /devel/setup.bash like I do for my other, regular catkin workspaces. I guess because the ROS-from-source workspace includes non-ROS packages this is really important.

Thanks jbohren for the help!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-06-09 23:57:38 -0600

Seen: 437 times

Last updated: Jun 10 '14