Local planner not correct

asked 2017-08-16 06:58:38 -0600

rosargh gravatar image

updated 2017-08-16 07:08:45 -0600

Hi,

I am using the amcl module from the navigation stack, and the dwa_local_planner. As you can see on the picture below, the global planner seems to be correct while the local planner is not, therefore my robot gets stuck.

trajectory

My sim_time (from dwa_local_planner_params.yaml) is set to 1.0. max_vel_x was originally set to 1.0 and I set it to 0.55 but nothing changed. In costmap_common_params.yaml, I've tried to set the z_voxels parameter to 20, although it originally was set to 2, but it didn't change anything.

Finally, in local_costmap_params.yaml, I changed the resolution to 0.1 instead of 0.05, but it didn't work.

Do you have any idea as to why it isn't working the way I would like it to?

Thank you for your help.

edit retag flag offensive close merge delete

Comments

Could I ask you to attach your image directly to your question? I've given you enough karma to do so.

Thanks.

gvdhoorn gravatar imagegvdhoorn ( 2017-08-16 07:07:18 -0600 )edit

I also have changed values in the local planner yaml and the changes appear to be ignored. sim_time, max and min speeds. Some entries in my log that may be related are 198(Costmap2DROS::resetOldParameters) Loading from pre-hydro parameter style

[/tmp/binarydeb/ros-melodic-dwa-local-planner-1.16.2/src/dwa_planner.cpp:147(DWAPlanner::DWAPlanner)] Sim period is set to 0.10 ( a different value that what is in yaml) Recovery behavior will clear layer obstacles (showed up twice) Setting goal: Frame:map, Position(0.545, -0.393, 0.000), Orientation(0.000, 0.000, -0.020, 1.000) = Angle: -0.040 in dwa_planner_ros.cpp:150 (DWAPlannerROS::setPlan) Got new plan in dwa_planner_ros.cpp 386(DWAPlannerROS::computeVelocityCommands) DWA planner failed to produce path. (these 2 repeat in an area with 1 meter clear all around) buffer_core.cpp:126 Invalid argument passed to canTransform argument source_frame in tf2 frame_ids cannot be empty it starts recovery ...(more)

ed gravatar imageed ( 2019-11-27 18:54:35 -0600 )edit

I also saw Parameter max_trans_vel is deprecated (and will not load properly). Use max_vel_trans instead. when my yaml had max_vel_trans not max_trans_vel

ed gravatar imageed ( 2019-11-27 19:40:14 -0600 )edit