Ask Your Question
0

Playback issues with large rosbag files [closed]

asked 2017-08-02 08:24:27 -0500

vkee gravatar image

updated 2017-08-02 08:24:53 -0500

Hi,

I'm running into issues playing back large rosbag files (> 1GB, they are bags generated of the KITTI dataset using this tool https://github.com/tomas789/kitti2bag for those that are interested).

The overall performance (particularly the tf) performance varies greatly, and is particularly poor the first time the bag is played. I suspect that the bag needs to be loaded into memory / cache for proper behavior.

I am playing the bags using sim time set to true and the clock option for rosbag play (the issues remain with the options off too).

Does anyone have ideas about the causes and fixes/workarounds?

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by vkee
close date 2017-08-03 05:25:47.558628

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-08-02 15:46:08 -0500

Wolf gravatar image

This is not rosbag functionality but the OS has a Disk cache that makes following calls faster than the first one. See this:

http://answers.ros.org/question/21184...

You might be able to preload the file into cache using a tool called vmtouch, See:

https://serverfault.com/questions/406...

https://serverfault.com/questions/433...

https://hoytech.com/vmtouch/

edit flag offensive delete link more

Comments

Thanks this helped a lot, vmtouch works great and solved my issue!

vkee gravatar image vkee  ( 2017-08-03 04:05:44 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2017-08-02 08:24:27 -0500

Seen: 330 times

Last updated: Aug 02 '17