Ask Your Question
0

rqt-graph error

asked 2017-07-31 15:54:23 -0600

cmacks gravatar image

updated 2017-08-13 15:18:38 -0600

I have installed, uninstalled, reinstalled the rqt packages using "sudo apt-get install ros-kinetic-rqt" i also did the same for the common-plugins. I keep getting the following:

nvidia@tegra-ubuntu:~$ rosrun rqt-graph rqt-graph [rospack] Error: package 'rqt-graph' not found

I tried running it in anew terminal as well... Still no luck. I am running this on a Jetson tx2. Any advice? Ive also tried the apt get update commands but theyre all up to date. Couldnt find much help looking through the other questions on rqt.

Just for my own eduification i looked in the file system /opt/ros/kinetic/share/rqt and the same for rqt-common-plugins. Both only contain a package.xml file.

also i do have a rqt-graph folder with a cmake folder, resource, package.xml and plugin.xml

EDIT: SO i reinstalled the full package. Same issue still occuring. Im not sure why im having this issue. Is it just that rqt is not compatible with the Nvidia Jetson?

edit retag flag offensive close merge delete

Comments

How did you install ROS? Did you setup your environment properly?

jayess gravatar image jayess  ( 2017-07-31 16:57:40 -0600 )edit

I installed ros using the Jetson Hacks InstallRosTX2 package they made. I also did check that all of my files are in order. Ive run roswtf as well to check for any errors. I dont believe the normal ros install works on this board which is why they wrote a custom install script

cmacks gravatar image cmacks  ( 2017-07-31 17:40:14 -0600 )edit

Were you ever able to figure out how to get the rqt command to work properly while using a jetson tx2? I am having the same issue.

aatzil gravatar image aatzil  ( 2018-11-01 12:47:55 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-07-31 17:49:45 -0600

jayess gravatar image

updated 2017-07-31 17:57:50 -0600

If you look at the install script from the jetsonhacks GitHub repo, you'll notice on line 13 that it runs sudo apt-get install ros-kinetic-ros-base -y which will install only the ROS base. The ROS base version does not include any GUI tools according to the install page on the wiki.

After installing, run rqt to see if it works.

Edit: This may not apply, I re-read your question and I missed the part about you installing and re-installing rqt and rqt-common-plugins.

edit flag offensive delete link more

Comments

omg... i didn't even see that. How would i go about installing full version then? Im assumign its just sudo apt-get intsall ros-kinetic-ros-desktop-full ?

cmacks gravatar image cmacks  ( 2017-07-31 17:52:17 -0600 )edit

Yeah, that's one way to do it but that would install everything. sudo apt-get install ros-kinetic-rqt ros-kinetic-rqt-common-plugins should install it, but as you've said you already tried that.

jayess gravatar image jayess  ( 2017-07-31 17:55:16 -0600 )edit
0

answered 2017-08-13 15:32:44 -0600

Dirk Thomas gravatar image

The package name is rqt_graph - not rqt-graph - so you might want to try the same command with underscores instead of dashes.

Only the Debian package name users dashes since underscores are not permitted.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-31 15:54:23 -0600

Seen: 1,275 times

Last updated: Aug 13 '17