Ask Your Question
0

I cant control my rplidar(can't stop)

asked 2017-07-31 05:05:09 -0500

Kang gravatar image

Hello, everyone I have a question for you. my environment is Raspberry pi 3, Ubuntu mate 16.04 LTS, rplidar A2. I just follow rplidar tutorial(http://wiki.ros.org/rplidar)

everything is ok, but when i killed rplidar(press Ctrl+C), terminal show me : shutting down processing monitor complete BUT, lidar continues to work(spining), How can i stop rplidar ?

Do i have to do extra work? or something i forgot? Please answer me how to solve the problem.

edit retag flag offensive close merge delete

Comments

Not very familiar with rplidar, but shouldn't it always spin while powered? By killing a node you are basically killing the driver only.

Procópio gravatar imageProcópio ( 2017-07-31 05:14:10 -0500 )edit

the RPLidar A2 driver (should) starts and stops the motor on launch and exit respectively.

naveedhd gravatar imagenaveedhd ( 2017-08-02 08:06:04 -0500 )edit

can you share the source of that information?

Procópio gravatar imageProcópio ( 2017-08-09 02:47:45 -0500 )edit

In official node here and nodelet's implementation here

naveedhd gravatar imagenaveedhd ( 2017-08-09 06:59:42 -0500 )edit

I dont have any idea about how kill a node. can you show me command?

Kang gravatar imageKang ( 2017-08-30 08:25:14 -0500 )edit

@naveedhd i just know when i stoped RPLidar, just press Ctrl+C, i don't know how kill respective node.

Kang gravatar imageKang ( 2017-08-30 08:26:58 -0500 )edit

@naveedhd I appreciate it. Thanks.

Kang gravatar imageKang ( 2017-08-30 08:27:41 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-09-10 08:36:59 -0500

Kang gravatar image

I did 2 solutions about my problem.

  1. Power problem
  2. it looks power problem about my rplidar.
  3. i used 5V/1A power connect. but when i see CPU monitor, i think it was lack about using RPlidar
  4. so i connect power-supplied USB 3.0 hub with RPlidar.

  5. add 2 lines of command

  6. when i use rplidar i always insert 2 lines of command $ source /home/{user}/catkin_ws/devel/setup.bash $ source /opt/ros/kinetic/setup.bash

with 2 solutions, i can start , stop my rplidar.

edit flag offensive delete link more
0

answered 2017-09-07 01:16:17 -0500

I have a quite similar situation with you. I use Raspberry pi, jessie, rplidar A2.

I met the situation when raspberry is powered by another robot.

However, when I use rplidar with my PC ubuntu, 14.04 LTS everything works well.

It also works well if I use a stable power source. So I think the problem may be the power supply.

Maybe you can check your power support for raspberry or rplidar.

By the way, to stop the lidar, you can run rosservice call /stop_motor. Ctrl+C should also works.

edit flag offensive delete link more

Comments

Thnks I solved it. It was lack of power. so i connect power-supplied USB 3.0 hub and Rplidar.

Kang gravatar imageKang ( 2017-09-10 08:33:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-31 05:05:09 -0500

Seen: 865 times

Last updated: Sep 10 '17