Ask Your Question
1

Help with gmapping results using (slower) rplidar on turtlebot2

asked 2014-09-03 06:10:23 -0500

mrsoft99 gravatar image

I mounted my new Robopeak rplidar on the center of the turtlebot's top plate, and modified the various launch/urdf to use this scanner for gmapping. However I have not modified any of the gmapping parameters, I'm using the same files as the turtlebot gmapping tutorials.

I can teleop around and get a map, but the walls are rather thick and fuzzy. I suspect this is a result of the rplidar publishing at only 5 hz, not 50 hz as the original kinect. Or possibly because the rplidar is 360 degrees and kinect was only 57 degrees?

Does anyone know why my map doesn't show a sharp defined wall? Is the slower publishing rate responsible? What params for gmapping should I modify to optimize for the slower rate?

I tried to add a small jpg of the map image, but not enough points.

This is on Hydro/Ubuntu 12.04, using a turtlebot2 (kobuki).

thanks buddy

edit retag flag offensive close merge delete

Comments

At what speed you are driving robot ?

bvbdort gravatar image bvbdort  ( 2014-09-03 09:18:37 -0500 )edit

Excuse me, dear mrsoft99, I'm sorry to interrupt you. But I am facing a problem about gmapping with rplidar on turtlebot2, I am just starting to ROS, and I am struggling with this problem for a week. Could you teach me how to modify the launch/urdf?

tanghz gravatar image tanghz  ( 2014-12-18 21:30:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-16 06:15:50 -0500

Maybe you already solve the problem. If not you can find here how to make RPLidar works with GMapping.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-09-03 06:10:23 -0500

Seen: 895 times

Last updated: Apr 16 '15