Ask Your Question
0

catkin_make fails with Invalid email and Invalid package [closed]

asked 2017-07-20 03:16:39 -0500

Parr gravatar image

updated 2017-07-25 02:35:44 -0500

When I try to catkin_make my workspace the following is output:

Base path: /home/user/catkin_ws
Source space: /home/user/catkin_ws/src
Build space: /home/user/catkin_ws/build
Devel space: /home/user/catkin_ws/devel
Install space: /home/user/catkin_ws/install
Package name "${pkg_name}" does not follow naming conventions
Invalid email "${email}" for person "${author}"
Invalid email "${email}" for person "${author}"

When I try to launch a launchfile which had been working fine before (and nothing changed on the file or the related files):

Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/__init__.py", line 225, in main
    args = rlutil.resolve_launch_arguments(args)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/rlutil.py", line 92, in resolve_launch_arguments
    resolved = roslib.packages.find_resource(args[0], args[1])
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslib/packages.py", line 504, in find_resource
    source_path_to_packages=source_path_to_packages)
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/catkin/find_in_workspaces.py", line 143, in find_in_workspaces
    source_path_to_packages[source_path] = find_packages(source_path)
  File "/usr/lib/python2.7/dist-packages/catkin_pkg/packages.py", line 87, in find_packages
    packages = find_packages_allowing_duplicates(basepath, exclude_paths=exclude_paths, 
exclude_subspaces=exclude_subspaces, warnings=warnings)
  File "/usr/lib/python2.7/dist-packages/catkin_pkg/packages.py", line 137, in find_packages_allowing_duplicates
    xml, filename=filename, warnings=warnings)
  File "/usr/lib/python2.7/dist-packages/catkin_pkg/package.py", line 589, in parse_package_string
    pkg.validate(warnings=warnings)
  File "/usr/lib/python2.7/dist-packages/catkin_pkg/package.py", line 268, in validate
    raise InvalidPackage('\n'.join(errors))
InvalidPackage: Package name "${pkg_name}" does not follow naming conventions
Invalid email "${email}" for person "${author}"
Invalid email "${email}" for person "${author}"

What I did do before this occurred was following the "Create your rqt plugin package" tutorial and at some point ran cmake on the package which added a bunch of folders and files to my catkin workspace (in retrospect, I think I misunderstood the wording on the tutorial...) I tried deleting the new stuff but that just caused more errors.

I'm not sure what exactly happened and how to fix it. Any help is appreciated.

EDIT: The problem turned out to be exactly what the error message said, there was actually a package.xml with the placeholders ${pkg_name} etc in the catkin workspace. Removed that and everything worked again.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Parr
close date 2017-07-25 02:39:14.982630

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-07-25 02:38:51 -0500

Parr gravatar image

Sorry I was unclear, I had removed the new files but since that caused even more problems, put them back again. I took another look and there was actually a package.xml with the placeholders, removing that solved the problem.

edit flag offensive delete link more
1

answered 2017-07-20 06:03:11 -0500

gvdhoorn gravatar image

Try removing:

  • /home/user/catkin_ws/build
  • /home/user/catkin_ws/devel
  • /home/user/catkin_ws/install

then run catkin_make (or catkin build) again.

edit flag offensive delete link more

Comments

that just creates the build and devel folders again (empty) and creates the same output:

Package name "${pkg_name}" does not follow naming conventions
Invalid email "${email}" for person "${author}"
Invalid email "${email}" for person "${author}"
Parr gravatar imageParr ( 2017-07-21 02:10:14 -0500 )edit

Well, yes. But I had understood from your "I tried deleting the new stuff" that you removed the offending pkg(s). In that case removing those build folders should have reset things.

gvdhoorn gravatar imagegvdhoorn ( 2017-07-21 03:01:56 -0500 )edit

I'm unsure whether this is actually a pkg that has a problem or if it's catkin or rospkg itself. What is the output of grep '{author}' -r /home/user/catkin_ws?

gvdhoorn gravatar imagegvdhoorn ( 2017-07-21 03:02:59 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-07-20 03:16:39 -0500

Seen: 614 times

Last updated: Jul 25 '17