Ask Your Question
0

How to solve the error "cannot marshal None unless allow_none is enabled ”

asked 2017-07-19 23:50:50 -0600

pratikshriniwar gravatar image

updated 2017-07-20 01:38:58 -0600

gvdhoorn gravatar image

Hi, I am new to ros. we are trying to interface the dynamixel Pro-42 series actuator to our hardware. we are following steps mentioned in tutorial "http://wiki.ros.org/dynamixel_controllers/Tutorials/ConnectingToDynamixelBus"

the problem is when we give command

roslaunch my_dynamixel_tutorial controller_manager.launch

on console it prints two messages that are:

load_parameter : Last successfully loaded parameter (/dev/ttyUSB0)
  "cannot marshal None unless allow_none is enabled"
File "/usr/lib/python2.7/xmlrpclib.py", line 664, in dump_nil
  raise TypeError, "cannot marshal None unless allow_none is enabled
"TypeError: cannot marshal None unless allow_none is enabled

How do i solve this issue..

<!-- -*- mode: XML -*- -->

<launch>
<node name="dynamixel_manager" pkg="dynamixel_controllers" type="controller_manager.py" required="true" output="screen">
<rosparam>
namespace: dxl_manager
serial_ports:
pan_tilt_port:
port_name: "/dev/ttyUSB0"
baud_rate: 57600
min_motor_id: 1
max_motor_id: 25
update_rate: 20
</rosparam>
</node>
</launch>

thanks in advance..

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-07-20 01:40:09 -0600

gvdhoorn gravatar image

updated 2017-07-20 01:40:22 -0600

serial_ports:
pan_tilt_port:

I've no experience with that particular node or the whole Dynamixel infrastructure, but it could well be that empty values for keys in yaml dicts are not allowed.

If you don't need those parameters, either remove or comment them.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-19 23:50:50 -0600

Seen: 1,082 times

Last updated: Jul 20 '17