rtabmap with ZR300 [closed]

asked 2017-07-19 11:11:56 -0600

robdan gravatar image

updated 2017-07-19 11:23:01 -0600

Hello all,

Having a little trouble with using rtabmap with ZR300. Trying to just do the hand held mapping with visual odom, but odom seems to have trouble with the environment

Error: OdometryF2M.cpp:372::computeTransform() Registration failed: "Not enough inliers 0/20 between -1 and 0"

Also, for some reason the map cloud is quite sparse (but the point cloud looks fine), despite me changing the following params:

param name="decimation" type="double" value="1"/

param name="voxel_size" type="double" value="0.0001"/

The below images show the pointcloud and the map cloud respectively

Thanks, any pointers would be a great help!

Point cloud

Map cloud

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by robdan
close date 2017-07-27 05:09:44.814801

Comments

Could I ask you to please attach the images to your question instead of hosting them off-board? I've given you enough karma to do so.

gvdhoorn gravatar image gvdhoorn  ( 2017-07-19 11:17:43 -0600 )edit

yeup! Thanks!

robdan gravatar image robdan  ( 2017-07-19 11:21:46 -0600 )edit

Can you show command lines used? Did you follow instructions from this tutorial for ZR300?

matlabbe gravatar image matlabbe  ( 2017-07-26 15:25:34 -0600 )edit

Oh sorry I forgot to update. I am still not sure what I did to fix the problem, but I reinstalled and it worked. Thanks!

robdan gravatar image robdan  ( 2017-07-27 05:09:06 -0600 )edit