ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Rtabmap not working

asked 2021-02-23 10:10:30 -0500

liambroek gravatar image

updated 2021-02-23 10:12:29 -0500

I'm using a realsense d435 on a raspberry pi 4 running ROS melodic. If follow the rtabmap tutorials I am able to perform handheld mapping successfully. Now I am trying to set this up on my turtlebot. I have installed the realsense-ros package on the raspberry pi. I imagine that I would run the realsense node on the pi, and then the rtabmap launch file on my remote pc. This results in an error:

rtabmap/rtabmapviz: Did not receive data since 5 seconds! Make sure the input topics are published ("$ rostopic hz my_topic") and the timestamps in their header are set. If topics are coming from different computers, make sure the clocks of the computers are synchronized ("ntpdate"). Parameter "approx_sync" is false, which means that input topics should have all the exact timestamp for the callback to be called. /rtabmap/rtabmapviz subscribed to (exact sync): /rtabmap/odom \ /camera/color/image_raw \ /camera/aligned_depth_to_color/image_raw \ /camera/color/camera_info \ /rtabmap/odom_info

This warning repeats and no map is generated.

I can view the pointcloud data in rviz, so data is definitely being published. Also when I echo the topics I can view the data (not the rtabmap topics but the camera topics). Is there something I am missing?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-02-23 12:26:17 -0500

mugetsu gravatar image

try setting approx_sync to true. Could be some of the topics don't have sync'd timesteps. I had an easier time by using rgbd_sync to avoid synchronization issues further.

http://wiki.ros.org/rtabmap_ros#rtabm...

edit flag offensive delete link more

Comments

Thanks that helped. Turns out it was a data transfer issue which was causing synchronization issues. Lowered the FPS of the camera, set enable_sync:=true, initial_reset:=true, and increased the queue size of rtabmap and it started to work. It's not great, still some issues, but I think if I mess around with the parameters a little more I should get it running smoothly. This link also helped a bit.

liambroek gravatar image liambroek  ( 2021-02-24 04:37:35 -0500 )edit

Hello, I'm facing the exact same issue. Ubuntu 18.04 on a remote PC and a raspberry pi 4 communicating through WiFi and a roscore master running on the PC. @liambroek could you please provide some details of how you solve your issue.

Thanks

bdz gravatar image bdz  ( 2021-09-19 15:07:47 -0500 )edit

I suggest to use rostopic hz on topics that are subscribed remotly to see if there is a framerate issue, or just to see if the remote pc can subscribe and receive data from them. Sometimes, if you don't set ROS_IP properly on both computers, one computer can see the topic in rostopic list but won't receive data from it.

matlabbe gravatar image matlabbe  ( 2021-09-20 07:28:01 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2021-02-23 10:10:30 -0500

Seen: 1,246 times

Last updated: Feb 23 '21