Ask Your Question
0

Pocketsphinx fatal error

asked 2017-07-15 15:51:31 -0500

Martelogie gravatar image

updated 2017-07-15 15:52:42 -0500

when i run this commandroslaunch pocketsphinx robocup.launch

then it gives me error:

FATAL_ERROR: "fe_sigproc.c", line 405: Failed to create filterbank, frequency range does not match. Sample rate 8000.000000, FFT size 512, lowerf 4765.625000 < freq -15.625000 > upperf 4218.750000.

full :

started roslaunch server http://YourSoulisMine:44601/

SUMMARY
========

PARAMETERS
* /recognizer/dict: /home/meow/catkin...
* /recognizer/lm: /home/meow/catkin...
* /rosdistro: kinetic
* /rosversion: 1.12.7

NODES
/
recognizer (pocketsphinx/recognizer.py)
voice_cmd_vel (pocketsphinx/voice_cmd_vel.py)

auto-starting new master
process[master]: started with pid [3437]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 20ce8556-6898-11e7-88b0-08d40c6bd6ea
process[rosout-1]: started with pid [3450]
started core service [/rosout]
process[recognizer-2]: started with pid [3454]
process[voice_cmd_vel-3]: started with pid [3461]
INFO: cmd_ln.c(691): Parsing command line:
gst-pocketsphinx \
-samprate 8000 \
-cmn prior \
-fwdflat no \
-bestpath no \
-maxhmmpf 2000 \
-maxwpf 20 

Current configuration:
[NAME]      [DEFLT]     [VALUE]
-agc        none        none
-agcthresh  2.0     2.000000e+00
-alpha      0.97        9.700000e-01
-ascale     20.0        2.000000e+01
-aw     1       1
-backtrace  no      no
-beam       1e-48       1.000000e-48
-bestpath   yes     no
-bestpathlw 9.5     9.500000e+00
-bghist     no      no
-ceplen     13      13
-cmn        current     prior
-cmninit    8.0     8.0
-compallsen no      no
-debug              0
-dict               
-dictcase   no      no
-dither     no      no
-doublebw   no      no
-ds     1       1
-fdict              
-feat       1s_c_d_dd   1s_c_d_dd
-featparams         
-fillprob   1e-8        1.000000e-08
-frate      100     100
-fsg                
-fsgusealtpron  yes     yes
-fsgusefiller   yes     yes
-fwdflat    yes     no
-fwdflatbeam    1e-64       1.000000e-64
-fwdflatefwid   4       4
-fwdflatlw  8.5     8.500000e+00
-fwdflatsfwin   25      25
-fwdflatwbeam   7e-29       7.000000e-29
-fwdtree    yes     yes
-hmm                
-input_endian   little      little
-jsgf               
-kdmaxbbi   -1      -1
-kdmaxdepth 0       0
-kdtree             
-latsize    5000        5000
-lda                
-ldadim     0       0
-lextreedump    0       0
-lifter     0       0
-lm             
-lmctl              
-lmname     default     default
-logbase    1.0001      1.000100e+00
-logfn              
-logspec    no      no
-lowerf     133.33334   1.333333e+02
-lpbeam     1e-40       1.000000e-40
-lponlybeam 7e-29       7.000000e-29
-lw     6.5     6.500000e+00 
-maxhmmpf   -1      2000  
-maxnewoov  20      20
-maxwpf     -1      20
-mdef               
-mean                
-mfclogdir          
-min_endfr  0       0
-mixw               
-mixwfloor  0.0000001   1.000000e-07
-mllr               
-mmap       yes     yes
-ncep       13      13
-nfft       512     512 
-nfilt      40      40
-nwpen      1.0     1.000000e+00
-pbeam      1e-48       1.000000e-48
-pip        1.0     1.000000e+00
-pl_beam    1e-10       1.000000e-10
-pl_pbeam   1e-5        1.000000e-05
-pl_window  0       0
-rawlogdir          
-remove_dc  no      no
-round_filters  yes     yes
-samprate   16000       8.000000e+03
-seed       -1      -1
-sendump            
-senlogdir          
-senmgau            
-silprob    0.005       5.000000e-03
-smoothspec no      no
-svspec             
-tmat               
-tmatfloor  0.0001      1.000000e-04
-topn       4       4
-topn_beam  0       0
-toprule            
-transform  legacy      legacy
-unit_area  yes     yes
-upperf     6855.4976   6.855498e+03
-usewdphones    no      no
-uw     1.0     1.000000e+00
-var                
-varfloor   0.0001      1.000000e-04
-varnorm    no      no
-verbose    no      no
-warp_params            
-warp_type  inverse_linear  inverse_linear
-wbeam      7e-29       7.000000e-29
-wip        0.65        6.500000e-01
-wlen       0.025625    2.562500e-02

FATAL_ERROR: "fe_sigproc.c", line 405: Failed to create filterbank, frequency range does not match. Sample rate 
8000.000000, FFT size 512, lowerf 4765.625000 < freq -15.625000 > upperf 4218.750000 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-10-09 12:22:09 -0500

PankajBaranwal gravatar image

The node fails to find feat.param file in the location specified with -lm option within the node.
You need to correct the path of lm defined in robocup.launch
Make sure that the path it mentions exists.

If you are still having trouble, you should try out this new ROS package for pocketsphinx:
https://github.com/cmusphinx/ros-pock...
It is much easier to set it up, works out of the box and has better wiki.

And if you are still having trouble, you can simply open an issue. The package is actively maintained. Someone will answer your queries much sooner.

edit flag offensive delete link more
0

answered 2017-07-15 16:41:30 -0500

billy gravatar image

I can't comment on pocketsphinx specifically but setting the upper frequency at 6.8kHz when you're sampling at 8kHz doesn't seem correct.

I suggest you put the sample rate back to the default 16kHz or reduce the upperf to 3kHz. Those coefficients are for the FFT filter and the max frequency out of the filter should be a healthy margin below 50% of the sampling frequency.

edit flag offensive delete link more

Comments

i'm sorry for the stupid question but in which file i need to change rate?

Martelogie gravatar imageMartelogie ( 2017-07-15 17:17:11 -0500 )edit

No idea. Sorry. Never had to mess with the parameters. It worked out of the box for me. I'm not at home these days so cannot confirm that mine is setup differently.

billy gravatar imagebilly ( 2017-07-15 23:15:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-15 15:51:31 -0500

Seen: 215 times

Last updated: Oct 09 '17