ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

roslaunch error: ERROR: cannot launch node of type

asked 2016-08-14 02:36:03 -0500

Rithvik.Chuppala gravatar image

Hi all,

I am a beginner to ROS (Indigo and a 14.04 Ubuntu machine) and as a project, I tried to use Pocketsphinx ( ) to set a 2D nav goal in RVIZ for a turtlebot simulator. However, when I try launching using roslaunch pocketsphinx goto.launch it gives an error: ERROR: cannot launch node of type [pocketsphinx/]: can't locate node [] in package [pocketsphinx]

I have already sourced devel/setup.bash and devel/ and have done catkin_make

For the python program, (located at catkin_ws/src/pocketsphinx/nodes folder), I largely based it off of this:

I then proceeded to make a launch file (located at catkin_ws/src/pocketsphinx/demo folder):

<node name="recognizer" pkg="pocketsphinx" type="">
    <param name="lm" value="$(find pocketsphinx)/demo/goto.lm"/>
    <param name="dict" value="$(find pocketsphinx)/demo/goto.dic"/>
<node name="goto" pkg="pocketsphinx" type="" output="screen">
    <remap from="cmd_vel" to="/mobile_base/commands/velocity"/>

If anyone could tell me what I am doing wrong, it would be great!

Thanks, Rithvik

edit retag flag offensive close merge delete


Does your have the execute permission set?

ahendrix gravatar image ahendrix  ( 2016-08-14 12:07:00 -0500 )edit does not have execute permission set. I changed it and it works now! Thank you very much! :)

Rithvik.Chuppala gravatar image Rithvik.Chuppala  ( 2016-08-14 13:14:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-08-14 13:20:54 -0500

Rithvik.Chuppala gravatar image

As ahendrix suggested, didn't have execute permission set. To set execute permission I used: chmod +x ./ Now it seems to working fine!

edit flag offensive delete link more


Where did you get the files goto.lm and goto.dic? I am using your question as a guide to get pocketsphinx running. I'm on 14.04 but with Jade. Any help really appreciated.

billy gravatar image billy  ( 2016-08-16 00:32:36 -0500 )edit

Question Tools

1 follower


Asked: 2016-08-14 02:36:03 -0500

Seen: 4,924 times

Last updated: Aug 14 '16