Ask Your Question
0

Pocketsphinx recognizer.py does not work

asked 2017-07-14 03:56:52 -0500

Martelogie gravatar image

updated 2017-07-14 05:12:57 -0500

Hello, everyone! I'm trying to work with pocketsphinx for speech recognition and im currently using this Tutorial

but i have some troubles:

when i run this command roslaunch pocketsphinx turtlebot_voice_cmd.launch

then i got some errors:

Traceback (most recent call last):
  File "/home/meow/catkin_ws/src/pocketsphinx/nodes/recognizer.py", line 177, in <module>
  start = recognizer()
  File "/home/meow/catkin_ws/src/pocketsphinx/nodes/recognizer.py", line 73, in __init__
  self.start_recognizer()
  File "/home/meow/catkin_ws/src/pocketsphinx/nodes/recognizer.py", line 80, in start_recognizer
  self.pipeline = gst.parse_launch(self.launch_config)
  glib.GError: no element «vader»
Traceback (most recent call last):
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/rospy/core.py", line 467, in signal_shutdown
  h()
  File "/home/meow/catkin_ws/src/pocketsphinx/nodes/recognizer.py", line 131, in shutdown
  gtk.main_quit()
  RuntimeError: called outside of a mainloop
[recognizer-2] process has died [pid 15287, exit code 1, cmd /home/meow/catkin_ws/src/pocketsphinx/nodes/recognizer.py __name:=recognizer __log:=/home/meow/.ros/log/ec640724-686e-11e7-adcd-08d40c6bd6ea/recognizer-2.log].
log file: /home/meow/.ros/log/ec640724-686e-11e7-adcd-08d40c6bd6ea/recognizer-2*.log
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2017-10-07 12:31:30 -0500

PankajBaranwal gravatar image

You can use this version instead:
https://github.com/Pankaj-Baranwal/po...
It contains quite many updated features of pocketsphinx. And also supports backward compatibility.
So it will work perfectly! And it is well maintained. So, if you have issues working with it, you can simply open a new issue and the maintainer should respond with a solution soon!
It is well documented too. You can follow the wiki, or the blog posts here:
https://medium.com/@PankajB96/

edit flag offensive delete link more
0

answered 2017-08-06 05:34:03 -0500

updated 2017-08-06 05:41:43 -0500

I dont know why this post is closed previously.

I upgrade to kinetic from indigo recently. And my pocketsphinx does not work due to many issues.

i.e., glib.GError: no element "gconfaudiosrc" , this can be solved through this post: http://answers.ros.org/question/20509...

However, for
glib.GError: no element «vader» this issue, I cannot solve it by adding libraries.

Inspired from this post: http://answers.ros.org/question/26362... , I started looking for repos supporting kinetic by tring repos forked from mikeferguson/pocketsphinx. Finally I tried https://github.com/pLeminoq/pocketsphinx master branch and it works. remember to use git checkout master to change the branch...however the accuracy is no good currently

just use a different package without adding any more libraries. will update if anything new.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-14 03:56:52 -0500

Seen: 1,078 times

Last updated: Oct 07 '17