Ask Your Question

Schunk_lwa4p initialization error with ros_canopen

asked 2017-07-13 03:07:23 -0600

Rishabh gravatar image

Hello, I am trying to run the schunk lwa4p arm with ros_canopen package but was not able to initialize the robot. The nodes are running and the can is set up but the rosservice call /arm/driver/init was not able to initialize the robot. I am attaching the candump output of the service along with other outputs.

I am using the shunck_lwa4p package from schunk_robots.

Please find the link to the gist with respective files

edit retag flag offensive close merge delete


Which firmware version do you use?

Mathias Lüdtke gravatar imageMathias Lüdtke ( 2017-07-13 09:09:52 -0600 )edit

I am using ubuntu 14.04 as a docker on fedora 25 with ros indigo.

Rishabh gravatar imageRishabh ( 2017-07-14 02:29:23 -0600 )edit

I really meant the Schunk firmware version, the config in schunk_robots works for v0.63 only. (With some modification it might work with v0.65, we don't use it)

Mathias Lüdtke gravatar imageMathias Lüdtke ( 2017-07-14 02:50:17 -0600 )edit

The canalyzer shows the manufacturer software version as 65 Build:7589. I am not sure if that is the correct version for the configuration file we have.

Rishabh gravatar imageRishabh ( 2017-07-14 03:27:40 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2017-07-14 04:05:13 -0600

Mathias Lüdtke gravatar image

updated 2017-07-14 04:05:39 -0600

For v0.65 please try to set an initial operation mode, this worked for me in a beta version:

Add ParameterValue=1 to the DCF.

As an alternative you can add "6060": "1" to dcf_overlay.

edit flag offensive delete link more


The robot was initialized after I made the suggested changes. Thank you for the help.

Rishabh gravatar imageRishabh ( 2017-07-14 06:05:39 -0600 )edit

Although the robot initializes successfully, I am still not able to control the robot using the position controllers. I am spawning the controllers using the ros_control package and they are spawing successfully.

Rishabh gravatar imageRishabh ( 2017-07-14 09:00:58 -0600 )edit

Check the diagnostics for hints,.

Mathias Lüdtke gravatar imageMathias Lüdtke ( 2017-07-14 09:05:55 -0600 )edit

The drives are in the Profile position mode but I think to control the robot with the position controller I need to bring them in interpolated position mode. I will take a more detailed look at the diagnostics too.

Rishabh gravatar imageRishabh ( 2017-07-14 09:07:57 -0600 )edit

What to do for v0.67 ?

k5519995 gravatar imagek5519995 ( 2019-04-27 03:56:37 -0600 )edit

I guess the same(?)

Mathias Lüdtke gravatar imageMathias Lüdtke ( 2019-04-30 12:06:54 -0600 )edit

Yes. It's working

k5519995 gravatar imagek5519995 ( 2019-06-06 15:17:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2017-07-13 03:07:23 -0600

Seen: 175 times

Last updated: Jul 14 '17