Ask Your Question
0

Kinetic: Problems during installation of turtlebot_Simulator ..

asked 2017-07-04 11:03:28 -0600

Ritchie gravatar image

Hi All,

I was trying to install the binaries of the turtlebot_Simulator by the follwing way.

1) Installation by binarys of turtlebot-simulator

sudo apt-get install ros-kinetic-turtlebot-simulator

2) move files of packet to "src" folder

I tried before I get the hint to use the binaries, directly the source code "src" of my workspace "turtlebot_ws"

I also installed the source code package of turtlebot_simulator. git clone https://github.com/turtlebot/turtlebo...

3)Following files are now in the folder (inkl. turtlebot_simulator.git )

~/turtlebot_ws$ ls src

CMakeLists.txt setup_kobuki.sh turtlebot_capabilities turtlebot.rosinstall

README.md turtlebot turtlebot_capabilities.rosinstall turtlebot_simulator

setup_create.sh turtlebot_bringup turtlebot_description turtlebot_teleop

4) Compile the package

Enter the command: ~/turtlebot_ws$ catkin_make

5) Trying to start

When I trying to start the simulator, I get the following error message:

~/turtlebot_ws$ roslaunch turtlebot_gazebo turtlebot_world.launch

... logging to /home/ros/.ros/log/ebc2837c-60cb-11e7-baaa-000c29a91528/roslaunch-ubuntu-4167.log

Checking log directory for disk usage. This may take awhile.

Press Ctrl-C to interrupt

Done checking log file disk usage. Usage is <1GB.

Invalid <arg> tag: environment variable 'TURTLEBOT_GAZEBO_WORLD_FILE' is not set.

Arg xml is <arg default="$(env TURTLEBOT_GAZEBO_WORLD_FILE)" name="world_file"/>

The traceback for the exception was written to the log file

6) Here are my ROS Variables:

printenv | grep ROS

ROS_ROOT=/opt/ros/kinetic/share/ros

ROS_PACKAGE_PATH=/home/ros/turtlebot_ws/src:/opt/ros/kinetic/share

ROS_MASTER_URI=http://localhost:11311

ROSLISP_PACKAGE_DIRECTORIES=/home/ros/turtlebot_ws/devel/share/common-lisp

ROS_DISTRO=kinetic

ROS_ETC_DIR=/opt/ros/kinetic/etc/ros

Same for the turtle bot variables:

printenv | grep TURTLE

TURTLEBOT_3D_SENSOR=asus_xtion_pro

TURTLEBOT_STACKS=hexagons

TURTLEBOT_SIMULATION=false

TURTLEBOT_RAPP_PACKAGE_WHITELIST=[rocon_apps, turtlebot_rapps]

TURTLEBOT_SERIAL_PORT=/dev/kobuki

TURTLEBOT_BASE=kobuki

TURTLEBOT_RAPP_PACKAGE_BLACKLIST=[]

TURTLEBOT_TYPE=turtlebot

TURTLEBOT_BATTERY=/sys/class/power_supply/BAT0

TURTLEBOT_INTERACTIONS_LIST=[turtlebot_bringup/admin.interactions, turtlebot_bringup/documentation.interactions, turtlebot_bringup/pairing.interactions, turtlebot_bringup/visualisation.interactions]

TURTLEBOT_NAME=turtlebot

I do not know, if it is a failure to try install the binaries and the source code version ?

Later I would like to modify the source code to lern more about the system. Therefore, the goal for me would be to install and get run the source code version.

I am new in ROS and trying to get a foot into the door and need help.

Best regards Ritchie

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-04 11:12:45 -0600

Ritchie gravatar image

I guess I found the problem first problem by myself.

I enter the follwong command

export TURTLEBOT_GAZEBO_WORLD_FILE=~/turtlebot_ws/src/turtlebot_simulator/turtlebot_gazebo/worlds/playground.world

And now it starts.

Best regards R.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-04 11:03:28 -0600

Seen: 589 times

Last updated: Jul 04 '17