Ask Your Question
0

Cannot find node robot_pose_ekf ?

asked 2017-06-19 02:51:36 -0600

Anurag gravatar image

updated 2017-06-19 03:42:02 -0600

Procópio gravatar image

I installed robot_pose_ekf according to http://wiki.ros.org/robot_pose_ekf , but when I run the launch file, thisi is the errer I receive

SUMMARY
========

PARAMETERS
 * /robot_pose_ekf/base_footprint_frame: base_footprint
 * /robot_pose_ekf/freq: 30.0
 * /robot_pose_ekf/imu_used: True
 * /robot_pose_ekf/odom_used: True
 * /robot_pose_ekf/output_frame: odom_combined
 * /robot_pose_ekf/sensor_timeout: 1.0
 * /robot_pose_ekf/vo_used: True
 * /rosdistro: indigo
 * /rosversion: 1.11.21

NODES
  /
    robot_pose_ekf (robot_pose_ekf/robot_pose_ekf)

auto-starting new master
process[master]: started with pid [64634]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 7023c802-54c3-11e7-8be4-14feb5de14ae
process[rosout-1]: started with pid [64647]
started core service [/rosout]
ERROR: cannot launch node of type [robot_pose_ekf/robot_pose_ekf]: can't locate node [robot_pose_ekf] in package [robot_pose_ekf]

How do I debug thsi error?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-01-26 19:43:29 -0600

emilyfy gravatar image

I ran into the same problem because I had downloaded the source codes into my catkin workspace and compiled it. Deleting all the associated files and folders from the build/ and devel/ directories in my workspace and running catkin_make clean solved it for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-06-19 02:51:36 -0600

Seen: 395 times

Last updated: Jun 19 '17