Ask Your Question
1

ASUS Xtion 2 - how to intergrate in ros

asked 2017-06-16 16:13:41 -0600

aamir_khan_cvas gravatar image

Hi everyone,

was wondering if anyone has tried integrating xtion 2 into ros. I have recently obtained it and was wondering if anybody has experience with this new version of xtion. Also, the provided sdk(openni2) installs successfully but the given samples crashes complaining about segmentation error. any suggestions are welcome. thanks.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-07-18 05:09:25 -0600

rok gravatar image

This is not a real solution, but can be useful for others looking for the same issues, as there is nothing on the web addressing this at the moment. I came here looking for a fix for the same problem. I am not a ROS user, but I'm trying to use Xtion2 on Linux. The provided examples, like NiViewer crashes. I tried on different computers with different Ubuntu version, I managed to run it only on my computer, but only lowering the bandwidth as they suggest in the manual (however this solution doesn't work in any of the other computers I tested. It is due to a bandwidth problem. I am in contact with the support service and they told me that they are working for a solution, probably to be released as new firmware in August.

edit flag offensive delete link more

Comments

thank you for sharing your experience. for now, to get around, is to copy the library files and openni2 drivers after making the openni2 sdk provided on their website, and replacing these with the roslaunch files, have done the job. I hope this helps whoever is working with xtion2 and ros.

aamir_khan_cvas gravatar imageaamir_khan_cvas ( 2017-07-18 08:56:27 -0600 )edit

Hi, I am a relatively new student user using ROS Kinetic on Ubuntu 16.04LTS. Could you elaborate more on which library files and openni2 drivers I need to copy from the roslaunch files into the SDK? I cloned from the openni2_camera and openni2_launch repos but I do not see the lib files to copy.

jastion gravatar imagejastion ( 2017-07-26 09:23:15 -0600 )edit
1

answered 2017-07-26 20:03:22 -0600

eegozilla gravatar image

updated 2017-07-26 22:36:51 -0600

Perhaps, this is the bandwidth problem as the above answer said. I could work SimpleViewer app using USB2.0 on Ubuntu14.04 on my older pc. Therefore, the new firmware need to be released like using Xtion Pro Live with usb3.0 in order to solve this problem.

But if on Windows, I can work it only with USB3.0. It's strange.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-06-16 16:13:41 -0600

Seen: 1,491 times

Last updated: Jul 26 '17