ethz-asl elevation mapping not working

asked 2017-06-03 07:35:20 -0600

feignedjesse2 gravatar image

updated 2017-06-03 08:32:05 -0600


I'm working on a project where i want to navigate rough terrain. I have a kinect, together with the freenect and rtabmap packages I can create a 3d map. Now i want to get the elevation mapping package from ethz-asl running ( ). Now I created a node which converts the pose output from rtabmap to the required "odomwithcovariance". I also made a tf-publisher which publishes "Robot_Base" in reference to the kinect.

I made a launch file with all the neccesary parameters:


<node name="Elevation_Map" type="elevation_mapping" pkg="elevation_mapping" respawn="false" output="screen">
    <param name="point_cloud_topic" value="/rtabmap/cloud_map"/>
    <param name="robot_pose_topic" value="/rtabmap/odomwithcovariance"/>
    <param name="map_frame_id" value="/map"/>
    <param name="base_frame_id" value="/Robot_Base"/>
    <param name="track_point_frame_id" value="/Robot_Base"/>
    <param name="resolution" value="0.1"/>


But when I run the package I only get the message "elevation map is updated without data from the sensor". and when I use the terminal and rospack echo on the topic all values are NaN.

can anyone help me please? author is not responsing on my question on his page on github

Thank you in advance, Jesse

edit retag flag offensive close merge delete


Hi, were you able to figure this out? My guess is that NaN is ok since that relates to unsearched space. I am wondering if you had any issues with the covariance param? Their documentation asks for a string, but the covariance is a list of floats. Any tips?

jetfire gravatar image jetfire  ( 2017-11-29 14:27:08 -0600 )edit