ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ros package can NOT find, error with [rospack] [closed]

asked 2017-06-02 13:09:18 -0500

Abdu gravatar image

updated 2017-06-03 08:35:07 -0500

I just installed ros kinetic on ubuntu 16.04.2. I am trying to run kinect v2, but I failed with several attempts

when I run 'abdulrahman@abdulrahman-ThinkPad-X230-Tablet:~/libfreenect2/build/bin$ ./Protonect', it works fine, but I can not run the following codes

'rosrun kinect2_viewer kinect2_viewer sd cloud'
'rosrun kinect2_bridge kinect2_bridge'

I always get this error

 'abdulrahman@abdulrahman-ThinkPad-X230-Tablet:~$ rosrun kinect2_viewer kinect2_viewer sd cloud'
  '[rospack] Error: package 'kinect2_viewer' not found'

even I tried this, but same error

abdulrahman@abdulrahman-ThinkPad-X230-Tablet:~$ rosrun kinect2_bridge kinect2_bridge _reg_method:=cpu
[rospack] Error: package 'kinect2_bridge' not found

any one can help please ?????

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Abdu
close date 2017-06-03 14:06:25.488969

1 Answer

Sort by ยป oldest newest most voted

answered 2017-06-03 10:48:44 -0500

Abdu gravatar image

I solved it, its silly mistake

When I run gedit ~/.bashrc in a terminal, there is no path in .bashcr file.

I just added the following two lines at the end of the file. Note/ this is for my path source, the path must be slightly different. The data between <.....> should be different.

source /opt/ros/<kinetic>/setup.bash
source /<home/abdulrahman/catkin_ws>/devel/setup.bash
edit flag offensive delete link more

Question Tools



Asked: 2017-06-02 13:09:18 -0500

Seen: 879 times

Last updated: Jun 03 '17