ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

sound_play has no sound and no errors

asked 2017-06-02 12:17:21 -0500

kingpinzs gravatar image

updated 2017-06-02 14:30:04 -0500

I an using ROS kinetic on a raspberry pi 3 model B with RASPBIAN JESSIE LITE distro installed. I used this tutorial to install ROS I ran the roscore and rosrun sound_play then I ran rosrun sound_play "Hello" also tried rosrun sound_play /usr/share/sounds/alsa/Noise.wav and rosrun sound_play 2

I get no sound output

this however will play sound aplay /usr/share/sounds/alsa/Noise.wav

Any idea or ways to troubleshoot sound_play?

Thank you

edit retag flag offensive close merge delete


did u solved it? how?

dinesh gravatar image dinesh  ( 2020-04-22 04:54:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2020-06-08 05:55:15 -0500

5tan gravatar image

I have had similar issue

Workaround: sudo apt install libgstreamer1.0-0 gstreamer1.0-pulseaudio gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad

edit flag offensive delete link more

Question Tools


Asked: 2017-06-02 12:17:21 -0500

Seen: 992 times

Last updated: Jun 02 '17