Ask Your Question
0

Gazebo not running on ROS Kinetic and Ubuntu 16.04

asked 2017-05-16 08:43:15 -0600

stephen127 gravatar image

I am trying to run Gazebo on a virtual machine with ROS Kinetic and Ubuntu 16.04.

However, I ran into the following error. I searched it online. Some says to change SIGINT to INT. It still doesn't work. Could anyone help me with this?

VMware: vmw_ioctl_command error Invalid argument. Aborted (core dumped) /opt/ros/kinetic/lib/gazebo_ros/gazebo: 46: kill: invalid signal number or name: SIGINT

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-05-16 11:24:52 -0600

youngiif gravatar image

I think this may be similar to the error I was getting, which was related to accelerated 3d graphics in VMware Workstation. You could try doing what I did:

add the following to ~/.bashrc

export SVGA_VGPU10=0

Or maybe try disabling 'Accelerate 3D graphics' inside the vm settings.

edit flag offensive delete link more

Comments

Adding the command line to the bash file did resolve my issue. But disable the "Accelerate 3D graphics" did. Thanks!

stephen127 gravatar imagestephen127 ( 2017-05-16 22:25:29 -0600 )edit

Glad to hear it worked. I should have mentioned that if you use that .bashrc change, you would need to start gazebo from the terminal and not start it from the gui in order for the option to be applied.

youngiif gravatar imageyoungiif ( 2017-05-16 23:12:30 -0600 )edit

I did start the Gazebo from terminal after adding that command in the .bashrc. For some reason, it did not resolve the issue on my computer.

stephen127 gravatar imagestephen127 ( 2017-05-17 08:22:13 -0600 )edit

export SVGA_VGPU10=0

Worked for me w/ ROS kinetic/gazebo 7 in VMware workstation 14 (Ubuntu 16.04). Went from 5-6 FPS w/ 3-D graphics disabled to 60+ FPS w/ 3-D graphics enabled.

rjb0026 gravatar imagerjb0026 ( 2018-06-08 12:00:05 -0600 )edit
0

answered 2017-05-16 09:18:00 -0600

blevesque gravatar image

Maybe you could use Docker instead. There are dockerfiles containing Gazebo/Kinetic in the internation internet

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-05-16 08:43:15 -0600

Seen: 2,923 times

Last updated: May 16 '17