Ask Your Question
0

roslaunch Error: Cannot Launch Node of Type

asked 2017-05-08 02:15:32 -0600

abcdcadb gravatar image

I am trying to implement the following tutorial (

https://bitbucket.org/enddl22/autonom...

After following above instruction, everything almost is done, I ran "catkin build" without error. However when doing "roslaunch ./teleop_key.launch", I got this error: ERROR: cannot launch node of type [vrep_ros_clock_server/vrep_ros_clock_server_node]: can't locate node [vrep_ros_clock_server_node] in package [vrep_ros_clock_server]

I referred this link: http://answers.ros.org/question/67488... to find workaround. rospack find vrep_ros_clock_server gave me the correct address of package vrep_ros_clock_server. My OS: ubuntu 14.06 ROS Indigo (similar author of the instruction) I also tried as the above link, delete package and re-create using roscreate-pkg, but the error still exists

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-08 06:37:15 -0600

hc gravatar image

The correct way to run this is: roslaunch ackermann_robot teleop_key.launch. or whatever your node name is , `roslaunch <node_name> teleop_key.launch

Hope this helps!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-05-08 02:15:32 -0600

Seen: 777 times

Last updated: May 08 '17