CMake error installing Kinetic on Raspberry Pi 3

asked 2017-05-05 14:16:18 -0600

bstanard gravatar image

updated 2017-05-05 14:23:16 -0600

I ran the command sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic from the ROS wiki on installing ROS Kinetic on the Raspberry Pi and, after processing 130 out of 206, got the following error:

      <== Finished processing package [130 of 206]: 'visualization_msgs' ==> Processing catkin package: 'geometric_shapes'
    ==> Building with env: '/opt/ros/kinetic/env.sh'
    ==> cmake /home/pi/ros_catkin_ws/src/geometric_shapes -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G Unix Makefiles in '/home/pi/ros_catkin_ws/build_isolated/geometric_shapes'
    -- Boost version: 1.55.0
    -- Found the following Boost libraries:
    --   system
    --   filesystem
    CMake Error at CMakeLists.txt:24 (find_package):
      By not providing "FindEigen3.cmake" in CMAKE_MODULE_PATH this project has
      asked CMake to find a package configuration file provided by "Eigen3", but
      CMake did not find one.

      Could not find a package configuration file provided by "Eigen3" with any
      of the following names:

        Eigen3Config.cmake
        eigen3-config.cmake

      Add the installation prefix of "Eigen3" to CMAKE_PREFIX_PATH or set
      "Eigen3_DIR" to a directory containing one of the above files.  If "Eigen3"
      provides a separate development package or SDK, be sure it has been
      installed.


    -- Configuring incomplete, errors occurred!
    See also "/home/pi/ros_catkin_ws/build_isolated/geometric_shapes/CMakeFiles/CMakeOutput.log".
    <== Failed to process package 'geometric_shapes': 
      Command '['/opt/ros/kinetic/env.sh', 'cmake', '/home/pi/ros_catkin_ws/src/geometric_shapes', '-DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes', '-DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic', '-DCMAKE_BUILD_TYPE=Release', '-G', 'Unix Makefiles']' returned non-zero exit status 1 
Reproduce this error by running:
==> cd /home/pi/ros_catkin_ws/build_isolated/geometric_shapes && /opt/ros/kinetic/env.sh cmake /home/pi/ros_catkin_ws/src/geometric_shapes -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel_isolated/geometric_shapes -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic -DCMAKE_BUILD_TYPE=Release -G 'Unix Makefiles'

Command failed, exiting.

I'm not sure what to do next. I ran the command again, and got the same error, as I do when I run the code to reproduce the error. I'm fairly new at building code at this level of complexity (am a big fan of apt-get), so I'm at a loss. I see that making Eigen3 has been an issue, so I am willing to load another version rather than Kinetic if that seems to be the best path. Any suggestions?

Bill

my Pi:

> pi@raspberrypi:~/ros_catkin_ws $ cat/etc/os-release 
> PRETTY_NAME="Raspbian
> GNU/Linux 8 (jessie)" NAME="Raspbian
> GNU/Linux" VERSION_ID="8" VERSION="8
> (jessie)" ID=raspbian ID_LIKE=debian
edit retag flag offensive close merge delete

Comments

I had simular issues....had better luck with https://github.com/ROSbots/rosbots_se... got ros up and running and talking to my pc....you can skip the internet setup part if not needed.

rnunziata gravatar imagernunziata ( 2017-05-05 14:45:29 -0600 )edit

Do you have libeigen3-dev installed?

antipattern gravatar imageantipattern ( 2017-05-10 16:26:47 -0600 )edit

I do not think I installed anything other then run the script...however I did start from sd card loaded with dexterindustries gopio sd image

rnunziata gravatar imagernunziata ( 2017-05-10 19:40:30 -0600 )edit

That does not answer the question though. You can check with dpkg -l | grep libeigen3-dev.

antipattern gravatar imageantipattern ( 2017-05-10 19:44:08 -0600 )edit