Ask Your Question
0

Error in first workspace compilation - Raspberry PI 3 (Jessie) Indigo

asked 2016-11-13 00:09:28 -0500

fhfonsecaa gravatar image

Hello guys, sorry, I am a new user but I have already worked with ROS on Raspberry pi. I tried to replicate my results with the jessie version, the installation was perfect but when try to do the catkin_make I get this error and I could not solve it

pi@raspberrypi:~/ros_catkin_ws $ catkin_make
Base path: /home/pi/ros_catkin_ws
Source space: /home/pi/ros_catkin_ws/src
Build space: /home/pi/ros_catkin_ws/build
Devel space: /home/pi/ros_catkin_ws/devel
Install space: /home/pi/ros_catkin_ws/install
####
#### Running command: "cmake /home/pi/ros_catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/pi/ros_catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/pi/ros_catkin_ws/install -G Unix Makefiles" in "/home/pi/ros_catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/pi/ros_catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /opt/ros/indigo
-- This workspace overlays: /opt/ros/indigo
-- Using PYTHON_EXECUTABLE: /usr/bin/python
-- Using Debian Python package layout
-- Using empy: /usr/bin/empy
-- Using CATKIN_ENABLE_TESTING: ON
-- Call enable_testing()
-- Using CATKIN_TEST_RESULTS_DIR: /home/pi/ros_catkin_ws/build/test_results
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using Python nosetests: /usr/bin/nosetests-2.7
-- catkin 0.6.18
CMake Warning (dev) at catkin/CMakeLists.txt:5 (project):
  Policy CMP0048 is not set: project() command manages VERSION variables.
  Run "cmake --help-policy CMP0048" for policy details.  Use the cmake_policy
  command to set the policy and suppress this warning.

  The following variable(s) would be set to empty:

    catkin_VERSION
This warning is for project developers.  Use -Wno-dev to suppress it.

-- BUILD_SHARED_LIBS is on
CMake Error at /home/pi/ros_catkin_ws/build/catkin_generated/order_packages.cmake:2 (message):
  Invalid package manifest "/opt/ros/indigo/share/roslang/package.xml": The
  manifest contains invalid XML:

  no element found: line 1, column 0
Call Stack (most recent call first):
  catkin/cmake/catkin_workspace.cmake:42 (include)
  CMakeLists.txt:63 (catkin_workspace)


-- Configuring incomplete, errors occurred!
See also "/home/pi/ros_catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/ros_catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-06-03 19:28:07 -0500

fhfonsecaa gravatar image

updated 2017-06-03 19:28:40 -0500

In the end I solved it by reinstalling from the beginning the version of ROS Kinetic with specific instructions for Raspberry PI

Installing ROS Kinetic on the Raspberry Pi

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-11-13 00:09:28 -0500

Seen: 476 times

Last updated: Jun 03 '17