No module named 'SerialClient' on bringup

asked 2020-07-07 05:46:36 -0500

anonymous user


updated 2020-07-07 05:47:19 -0500


I'm trying to execute the bringup on a turtlebot3 but when I run the command: roslaunch turtlebot3_bringup turtlebot3_robot.launch, I get the following error:

Traceback (most recent call last):
  File "/home/ubuntu/catkin_ws/devel/lib/rosserial_python/", line 15, in <module>
    exec(compile(, python_script, 'exec'), context)

  File "/home/ubuntu/catkin_ws/src/turtlebot3/rosserial/rosserial_python/nodes/", line 39, in <module>
    from rosserial_python import SerialClient, RosSerialServer

  File "/home/ubuntu/catkin_ws/devel/lib/python3/dist-packages/rosserial_python/", line 34, in <module>

  File "<string>", line 1, in <module>

ModuleNotFoundError: No module named 'SerialClient'

Since I am using ROS Noetic, I had to download rosserial-python by source using the command:

git clone -b noetic-devel

And maybe this is why this isn't working. Is there any workaround to make this work well? I tried taking a look at the files that were described in the error message but I had no luck or any idea of how I could correct them. I believe that the error has to do with a confusion between Python2 and Python3 on the file on line 39:

from rosserial_python import SerialClient, RosSerialServer

I am trying to run this on a Raspberry Pi 3 on a turtlebot 3 waffle-pi. But I don't know what I should change to make it work. Can anyone help?

Thank you

edit retag flag offensive close merge delete


This would appear to be a duplicate of #q354667 (and a few others).

Please refer to the issue linked in the comments.

I would not suggest you follow the work-around described in the answer posted by the OP of that question.

gvdhoorn gravatar image gvdhoorn  ( 2020-07-07 07:01:58 -0500 )edit

If you think that following the work around described in the answer is not very good, what can I do to solve the issue?

anonymous userAnonymous ( 2020-07-09 03:20:04 -0500 )edit

This might be caused due to the fact that rosserial has not been properly updated to Python3 yet. They are working on updating it and the latest variant does seem to work but it hasn't been released yet.

This is the link to the issue that tracks the progress, you should be able to find the latest python files that work for ROS-noetic here.

This is the issue tracker for rosserial in ROS-noetic

Jsamwel gravatar image Jsamwel  ( 2020-07-31 03:08:13 -0500 )edit