Ask Your Question
0

interactive markers does not work with gmapping_demo

asked 2017-05-02 17:08:16 -0600

mrobot gravatar image

I am trying to do SLAM to map my room with my turtlebot. Using Indigo on turtlebot and Ubuntu 14.04, Ubuntu 14.04 on host PC. I can get the interactive markers to work and navigate the turtlebot just fine from the host PC following the tutorial here: interactive_markers When I try to run the mapping tutorial here: navigation The rviz comes up fine but without interactive markers as a selection. SO I tried running ON host PC:

roslaunch turtlebot_interactive_markers interactive_markers.launch --screen

and then I added the interactive markers using the add button from rviz, enabled it and tried clicking on the interactive button but nothing happens. The navigation by interactive markers does not come up. What do I need to do differently to get interactive_marker navigation to work during mapping?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-02 21:34:56 -0600

mrobot gravatar image

After comparing the configuration files in /turtlebot_rviz_launchers/rviz

I found what seems to be a solution. When you run

roslaunch turtlebot_rviz_launchers view_navigation.launch

It uses a configuration file navigation.rviz, if you compare that to the file used by

roslaunch turtlebot_rviz_launchers view_robot.launch

which is robot.rviz, you see that robot.rviz has lines in it to add the class rviz/InteractiveMarkers, evidently you can not simply add interactive markers from rviz gui, it must be declared in the configuration file first. The file navigation.rviz did not have these lines so I added them:

- Class: rviz/InteractiveMarkers
  Enabled: false
  Name: InteractiveMarkers
  Show Axes: false
  Show Descriptions: true
  Show Visual Aids: false
  Update Topic: /turtlebot_marker_server/update
  Value: false

Once I did this and launched rviz again with above commands, the interactive marker was in rviz and when I clicked on the interactive button, I could navigate using interactive markers while mapping was taking place. Of course you still have to run

roslaunch turtlebot_interactive_markers interactive_markers.launch --screen

I do not really understand the syntax in the *.rviz files. I could attach my modified navigation.rviz so others can do a diff and see where I changed it, but I don't have enough points. Maybe someone can tell me if what I did is the correct way to fix this issue or not.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-05-02 17:08:16 -0600

Seen: 174 times

Last updated: May 02 '17