Ask Your Question
2

Invalid parameter "robot_namespace" when running Husky Robot

asked 2017-05-02 03:00:48 -0500

nobinov gravatar image

Hi everyone.

I want to run Husky Robot ( http://wiki.ros.org/Robots/Husky ) in my Gazebo simulator. Current version for Husky in ROS is still in Indigo, and Kinetic version is still not released yet. So I cloned Husky code from https://github.com/husky/husky into src folder in my new catkin workspace, compiled it using catkin_make, and run one of the launch file there :

roslaunch husky_gazebo husky_empty_world.launch

Then I met this errors:

Invalid parameter "robot_namespace"
XacroException('Invalid parameter "robot_namespace"',)
when instantiating macro: sick_lms1xx (/opt/ros/kinetic/share/lms1xx/urdf/sick_lms1xx.urdf.xacro)
in file: /home/myuserame/myworkspace/src/husky/husky_description/urdf/husky.urdf.xacro
while processing /home/myuserame/myworkspace/src/husky/husky_gazebo/launch/spawn_husky.launch:
while processing /home/myuserame/myworkspace/src/husky/husky_description/launch/description.launch:
Invalid < param > tag: Cannot load command parameter [robot_description]: command [/opt/ros/kinetic/lib/xacro/xacro '/home/myuserame/myworkspace/src/husky/husky_description/urdf/husky.urdf.xacro'     --inorder     robot_namespace:=/     laser_enabled:=true     kinect_enabled:=false     urdf_extras:=     ] returned with code [2]. 

Param xml is < param command="$(find xacro)/xacro '$(find husky_description)/urdf/husky.urdf.xacro'     --inorder     robot_namespace:=$(arg robot_namespace)     laser_enabled:=$(arg laser_enabled)     kinect_enabled:=$(arg kinect_enabled)     urdf_extras:=$(arg urdf_extras)     " name="robot_description"/ >
The traceback for the exception was written to the log file

Am I missing something?

Thank you!

edit retag flag offensive close merge delete

Comments

I'm getting simillar error:

<:[2]~/catkin-ws$ /opt/ros/kinetic/lib/xacro/xacro '/home/adrian/catkin-ws/src/husky/husky_description/urdf/husky.urdf.xacro'     --inorder     robot_namespace:=/     laser_enabled:=true     kinect_enabled:=false     urdf_extras:=
abrzozowski gravatar imageabrzozowski ( 2017-05-10 02:21:43 -0500 )edit

XacroException('Invalid parameter "robot_namespace"',) when instantiating macro: sick_lms1xx (/opt/ros/kinetic/share/lms1xx/urdf/sick_lms1xx.urdf.xacro) in file: /home/adrian/catkin-ws/src/husky/husky_description/urdf/husky.urdf.xacro

abrzozowski gravatar imageabrzozowski ( 2017-05-10 02:22:00 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-05-12 02:49:07 -0500

nobinov gravatar image

Solved ! Sorry for my late confirmation

As i issued on their Github ( https://github.com/husky/husky ), they current version of LMS1xx on repo is not updated yet and not supported the newest version of Husky. Then just like abrzozowski said, it needs to use newest version of LMS1xx from source at https://github.com/clearpathrobotics/...

Further details please look at https://github.com/husky/husky/issues/49

edit flag offensive delete link more
0

answered 2017-05-10 03:02:22 -0500

abrzozowski gravatar image

updated 2017-05-10 03:02:58 -0500

If you cloned https://github.com/husky/husky repository, you should clone compatible lms1xx driver from https://github.com/clearpathrobotics/... too.

edit flag offensive delete link more

Comments

Yeah that works. thank you

nobinov gravatar imagenobinov ( 2017-05-12 02:48:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-02 02:45:11 -0500

Seen: 621 times

Last updated: May 12 '17