ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Catkin_make does not build rtabmap_ros¿

asked 2017-04-28 06:15:06 -0500

adr_arroyo gravatar image

Hello, this question is pretty similar to this one: although in my case I believe the package.xml is correctly set.
My problem is that when I run catkin_make it jumps over the rtabmap_ros package, with no output.
However, if I run catkin_make --pkg rtabmap_ros it says that the "catkin_ws/src/build/rtabmap_ros" folder does not exist, which of course is true as the command is supposed to build the project. The folder rtabmap_ros is directly downloaded from the repository and it works perfectly in my other computer.
Any ideas about how to proceed?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2017-04-28 07:25:32 -0500

matlabbe gravatar image

Try cleanup the catkin build directory and make again:

$ rm -r catkin_ws/src/build/*
$ cd catkin_ws
$ catkin_make
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-04-28 06:15:06 -0500

Seen: 152 times

Last updated: Apr 28 '17