Ask Your Question
1

ERROR with Map_Server. Not able to open .yaml file. Using prebuilt Map with AMCL launch file- how to execute with RVIZ.

asked 2017-03-21 14:04:33 -0600

Shilpan gravatar image

updated 2017-03-23 13:55:40 -0600

I currently have made my map using Hector Slam and saved the map as .yaml file and .pgm .

I have downloaded the Navigation stack as well using git source: https://github.com/ros-planning/navig... . Also ran catkin_make afterwards.

Now, I am trying to implement AMCL by placing my robot( irobot create 2) onto the map and do autonomous mapping.

I am getting an error when i run am amcl file... which says " MapServer could not open <.yaml> file." Please see attached for my code.

Screenshot from 2017-03-23 10-48-08.png

Update:

I was able to upload map onto RVIZ, and executed amcl with proper tf/ messages. However, when I move the robot towards a location, the PoseArray points do not move. Please recommend a suggestion. Here is the screen pic. Screenshot from 2017-03-23 14-55-11.png

edit retag flag offensive close merge delete

Comments

I ran the following commands simultaneously.. roslaunch hector_slam_launch tutorial.launch rosrun map_server map_server <file>.yaml roslaunch amcl amcl_diff.launch

but received message "No laser scan rece

Shilpan gravatar imageShilpan ( 2017-03-22 13:12:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-24 12:11:53 -0600

Shilpan gravatar image

rosrun map_server map_server <file_name>.yaml rosrun rviz rviz --> Add Map->topic /map

Issue resolved. Added tf code messages in AMCL launch file to configure with my robot.

Please see for follow up Q. link text

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-03-21 14:04:33 -0600

Seen: 793 times

Last updated: Mar 24 '17